On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • downloaded Revolution beta3.. installed with no errors and I can login and use the manager.

    but every time I try to install a package I get errors, such as tinymce. here’s a bit of the error I get in the console:

    Attempting to preserve files at /home/public_html/modx-2.0.0-beta/core/components/ into archive /home/public_html/modx-2.0.0-beta/core/packages/tinymce-3.2.0.1-beta3/modPlugin/de80ac29e176e35a0a44fbe7c0a804ae.2.preserved.zip
    PHP warning: Invalid argument supplied for foreach()
    Grabbing package workspace...
    Package found...now preparing to install.
    Could not install related objects for vehicle: Array (

    it goes on to show the license for tinymce in red.

    I’ve tried a number of clean revolution installs and always with the same result. Also tried a few different packages (editarea, cssratings) all produce similar results.

    Any ideas?
      Jeremy Foster
    • I am seeing the same warning messages in red when installing TinyMCE, but it is actually installing fine as far as I can tell, completing with the message:
      Successfully installed package tinymce-3.2.0.1-beta3

      Please confirm if the TinyMCE plugin is actually installed on your system.

      I’ll take a look at the errors being reported despite the apparent successful installation.
      • it’s available from the dropdown under the input box on new pages, but when I select it nothing happens, page refreshes and no tinymce.

        also upon trying to uninstall tinymce, the console message says it can’t find some files to remove.
          Jeremy Foster
        • Just a thought, check that your /core/packages directory is writeable by your webserver. I’m not sure if this is checked or not on install.
            Use MODx, or the cat gets it!
          • Quote from: jeremy at Sep 05, 2009, 02:32 AM

            it’s available from the dropdown under the input box on new pages, but when I select it nothing happens, page refreshes and no tinymce.
            I just meant did you get the "Successfully installed" message and does the TinyMCE plugin show up in your list of Plugins under the Elements tree. Whether or not it is operational once installed is a totally different issue than the package installation failing. However, if it is not working, yet installed, you can report the bug at http://svn.modxcms.com/jira/browse/TINYMCE.

            Quote from: jeremy at Sep 05, 2009, 02:32 AM

            also upon trying to uninstall tinymce, the console message says it can’t find some files to remove.
            There’s still a little work left to do on the new backup/restore features now available in the transport packages; the ultimate indicator of success though, is the message that says the package was successfully installed. These other messages are just there for feedback, though they may certainly indicate problems with the package itself or the package management features in the version of MODx Revolution you are using (so thanks for reporting them).