On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I guess it is a matter of definition to call it a custom LAMP stack. It is true that it is customized, but all of that is Ubuntu customization, it is actually a stock Ubuntu 9.04 setup I have.
    The errors seen on google on Ubuntu all relate to earlier versions of Ubuntu. These releases needed extra customization to get pdo_mysql installed, and it had to happen through PEAR. In Ubuntu 9.04, everything is installed through the php5-mysql package and enabled per default. Of course that does not mean that it Just Works(TM) but at least it is supposed to be easier.

    What is weird is that the INSERT query works (I can see the data shows up in the table), but SELECT does not return the correct result, since the data obviously exists in the table but the result set is empty. Of course, I can see that the select query is more complex than INSERT here, so it might be more sensitive to settings on my system.
    • I located the debug feature, so I enabled it for the manager. This is a log of first load and login attempt after setup from SVN branch 2.0. Interestingly enough, it does not show the INSERT query that succeeds, which can be seen on the database entry.
      • Turns out my other computer can run revolution without problems, but this is also Ubuntu 9.04 with same version as my laptop. Only difference I can see is some stuff in php.ini (upper bad, lower good):
        89c89
        < precision = 12
        ---
        > precision = 14
        267,268c267,268
        < max_execution_time = 120 ; Maximum execution time of each script, in seconds
        < max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
        ---
        > max_execution_time = 240 ; Maximum execution time of each script, in seconds
        > max_input_time = 240 ; Maximum amount of time each script may spend parsing request data
        317c317
        < error_reporting = E_ALL
        ---
        > error_reporting = E_ALL | E_STRICT
        371c371
        < ;html_errors = Off
        ---
        > html_errors = Off
        966c966
        < session.use_only_cookies = 1
        ---
        > ; session.use_only_cookies = 1
        1021,1022c1021,1022
        < session.bug_compat_42 = 0
        < session.bug_compat_warn = 0
        ---
        > session.bug_compat_42 = 1
        > session.bug_compat_warn = 1
        1060c1060
        < session.hash_function = 1
        ---
        > session.hash_function = 0

        edit: some more info can be seen here:
        laptop/bad setup http://jacob.larsen.net/phpinfo.html
        server/good setup http://jacob.larsen.net/phpinfo.php
        • Try tweaking the bad php.ini, focusing on the error_reporting and session.* entries one at a time until it works, restarting Apache each time of course. If you can help pinpoint the precise setting that is causing this problem, that would help immensely.

          BTW, if these are both stock installs, why is the php.ini different?
          • Just tried it. The one that changed it all is session.hash_function = 0. Seems Revolution needs MD5 (hash_function=0) hashing and cannot use SHA-1 (hash_function=1). Nice to finally get an explanation.

            The differences in php.ini turns out to be from some tweaking I did earlier, especially on the laptop to test some security-related stuff. Seems I forgot some of that again undecided
            • Quote from: Jacob at Sep 05, 2009, 06:17 PM

              Just tried it. The one that changed it all is session.hash_function = 0. Seems Revolution needs MD5 (hash_function=0) hashing and cannot use SHA-1 (hash_function=1). Nice to finally get an explanation.
              Indeed; thanks immensely for narrowing that down and finding this. I’ll enter a ticket in Jira and research this problem as soon as I can (unless someone else provides a patch first) smiley

              Cheers!
              • Quote from: OpenGeek at Sep 05, 2009, 06:22 PM

                (unless someone else provides a patch first) smiley

                Don’t look at me like that wink
                I might feel motivated to contribute to the project some time later but I need to understand the framework some more first.
                • Quote from: Jacob at Sep 05, 2009, 06:35 PM

                  Quote from: OpenGeek at Sep 05, 2009, 06:22 PM

                  (unless someone else provides a patch first) smiley

                  Don’t look at me like that wink
                  I might feel motivated to contribute to the project some time later but I need to understand the framework some more first.
                  I really just meant anyone, not specifically you. You’ve done your part! grin

                  Just FYI, this issue can be tracked at http://svn.modxcms.com/jira/browse/MODX-1207