Zend Optimizer does something here...the php.ini file is inside it:
Configuration File (php.ini) Path = /usr/local/Zend/etc/php.ini (from the phpinfo.php page).
Since the phpinfo page got it right what else do I need to do?
I put an htaccess in the root, program directory and the setup directory with:
php_value memory_limit 64M
I put a php.ini in the same locations with:
memory_limit = 64M
So that should cover everything right?
It still shows the memory error!
So I made the "$success=true; // ADD THIS LINE" change and it passes the test and then when selecting "next" it gives me a blank page.
I just don’t understand. This server is totally under my control from just about the biggest reseller out there so there must be many out there with the same issue...or?
Help!
-
MODX Staff
- 10,725 Posts
Let’s back up; if this is a dedicated server or VPS, why in the world would it be configured with suexec? The complications it brings and degraded performance are hardly worth it unless you are using a shared hosting environment. Of course, I avoid WHM/Cpanel like the plague, so my opinion on this may be biased.
Next, you cannot use .htaccess with suexec -- Apache is not in control of the directives for PHP.
Finally, I’m not familiar enough with suexec rules to know where/how the php.ini file needs to be configured per directory, or if it even can be. Can anyone else help out here if his host cannot provide this information?
The server came configured that way...they do it that way (I have others, this belongs to a friend).
So...I went to another server I have...and it is configured the same way.
This is obviously common if anybody is installing this in any numbers.
I have done a lot of checking and lots of Drupal installs have the same issues.
It is most likely the Zend optimizer, but as yet I have found no way around it.
I have a ticket into my server people.
Hard to believe I’m the only one with servers set up this way!
A number of people have had memory problems with intalling Revolution but I don’t recall seeing one just like yours. In fact, I’ve never seen a phpInfo() report that didn’t include a memory_limit value.
If you search for "memory_limit" in google you will find people talking about it. Try "Zend Memory Manager and memory_limit" and you’ll see others are as lost. Many Drupal installers have issues.
I have a ticket into my server and am uploading modX to another site which has the zend stuff but also shows the memory_limit...who knows. This particular server has great people so if there is an issue there they may find it.
The idea that this is an isolated issue must be because it is a beta and it has not hit the mainstream yet. Mark my words...there will be tons with this issue!
So I tried another server and got a different error:
FATAL ERROR: MODx Setup cannot continue.
* MODx requires the PDO extension when native PDO is being used and it does not appear to be loaded.
* MODx requires the pdo_mysql driver when native PDO is being used and it does not appear to be loaded.
So now I’ve gone through another server, that is 3 so far, all large managed servers (all come up one page one with a server search) and each has an error installing this. I went through the server requirements and they all 3 pass.
I’m starting to wonder if this is because it’s a beta or because it won’t work on very many servers?
I’ll wait to see if anyone here has any ideas and I’ll do another ticket to another server and see what happens.
Whew!
Really sorry about all the trouble you’re having. It will be a while before every possible installation issue is ironed out.
It’s fairly unusual for a PHP5 installation to have PDO turned off. MODx is built on xPDO (which is built on PDO) so it’s pretty critical that PDO be enabled.
See if this solves your PDO problem:
http://modxcms.com/forums/index.php/topic,31032.msg190899.html#msg190899
Had the same problem here.
(Xampp, windows, localmachine)
So I wanted to see what went wrong and added the $bytes variable in the error.
It came back with "64"
So somehow the calculation in the return_bytes function didn’t go well.
I changed php.ini and reloaded my Apache with different memory settings:
64m or 64M but both don’t seem to make a difference.
There’s more than one php.ini file. I think the one you want is in apache/bin.
I set mine to 128M
I set the right one. Like I said I added a "memory = $bytes" in the output to the screen in front of the error, so I could see what was being calculated rather and it just said 64. It did read 64M or 64m from the ini, but in the function to calculate the bytes (just below the code) it doesn’t do the calculation for $ml * 1024...
so bytes are returned as 64 instead of 64*1034....
Bypassing did make things work.