We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 35028
    • 5 Posts
    I’m having an issues with the internal server 500 error appearing randomly on our 2.1.3 sites. I’ve already checked our folder permissions, and the ’php_flag zlib.output_compression’ line is already commented out. The only thing I can think of is to edit the ’register_globals’ line in out php.ini file, but I’m quite confident that our server is setting PHP directives through the .htaccess. We’ve talked to people running the same version on the same server as us, and we’re the only one having issues like this. Could Filezilla be doing something weird to the permissions that I’m not seeing? I’m running out of ideas of what could be causing the server error.
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      This can happen if your server is running PHP as CGI with suexec. In this case, file permissions must be 644 and directory permissions must be 755. Any files/folders with world-writable permissions can cause a 500 error.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org