We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 21606
    • 46 Posts
    This error - "action_err_ns" is occurring on my installations on a specific host and I can’t seem to figure out the cause. One thing I noticed is that when installing packages no feedback is given, i.e. there are no workspace grabbing notices, etc. and when I clear the cache the error occurs. I’m quite sure it’s not specific to 2.1.2, but was happening with the previous version as well, I just didn’t find any error messages until upgrading in preparation to set up a new website.

    The environment:
    Apache 1.3.42
    PHP version 5.2.17
    MySQL version 5.1.56
    MODx 2.1.2-pl traditional
    Error log in MODx is clear

    If this is redundant - sorry - didn’t get a result in searching the forum, perhaps didn’t use the right term. Still looking.
      • 21606
      • 46 Posts
      Have found an answer, but not the precise answer...
      this last site installed is hosted on Lunar Pages - all other sites are someplace else. All other sites install and function perfectly so I was pretty sure it was some minor configuration at LP. Went digging through their forums and while reading about a completely unrelated problem found a reference to the htaccess file and it’s use. Renamed the file provided by MODx and things are now working. Don’t know what setting in the htaccess file is necessary, but there you have it.
      Lesson for the day: If it doesn’t work try htaccess. rolleyes
        • 33608
        • 27 Posts
        Just as an FYI, I just ran into a very similar issue, and renaming ht.access to .htaccess fixed it on my host also. I am setting up Revo 2.2 on Miva Merchant, so if you are using that host, this may happen to you as well.

        thanks nitrojane!
          • 3749
          • 24,544 Posts
          Interesting, I've never seen that fix anything before. There must be an .htaccess file higher up that's doing some odd rewriting.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 33982 ☆ A M B ☆
            • 476 Posts
            We just ran into this same problem as well. A new client has come to us and they had a MODX Revo install (version 2.2.1) running on a server and it stopped working altogether. We're not sure if it's a hosted related problem or MODX problems that kept the site from running. They wanted to move to a new server anyways, so we moved all the files over to the new server: Bluehost.com which is MODX friendly (and by MODX friendly I mean they have Fantastico enabled to install MODX on their server).

            So we went ahead and upgraded the site to run on 2.2.8 and we were able to get things running again. Now we're running into this problem. When attempting to save a document, we're getting an "Access Denied" error. So we went over to the Security >> Manage Users and instead of seeing the users, we see this:

            http://screencast.com/t/PAr8ukPJ4XIE

            It's the same error as above: "action_err_ns"

            We've attempted to perform the steps above with updating the .htaccess file but it didn't help. I went ahead and did a clean install of MODX on the server in a dev directory and everything is working fine on the dev modx install (just a base install).

            Not sure what to do now. The site will load, but we can't make any updates in the MODX manager.

            Here's what 1 thing I have really observed about the manager: every action made that has an ajax request, the MODX manager returns this error. Also, we were seeing this error before we did the upgrade.
              Precision Web Development ... SmashStack.com
              • 9207 ☆ A M B ☆
              • 2,475 Posts
              Sounds like maybe an environment issue -- are you running something like modSecurity or other firewall that may be blocking or otherwise filtering Ajax requests? Anything in your logs?
                • 3749
                • 24,544 Posts
                The message usually means that manager's request method has been called with an action that doesn't exist.

                Look at the URL in the browser's address bar when you go to Security -> Manage Users and make a note of the action number. Typically, the URL would end with manager/?a=49.

                In PhpMyAdmin, look at the modx_actions table (note: *not* modx_access_actions), you should see a record with the same Id with security/users in the action field. While you're there, try repairing all tables.

                Assuming that you've tried manually deleting all files in the core/cache directory, clearing your browser cache and cookies, and turning off the compress_js and compress_css System Settings, I'd suspect either a corrupted DB table, or a corrupted or missing file in the install (especially if you transferred the files individually with FTP).

                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 33982 ☆ A M B ☆
                  • 476 Posts
                  Quote from: Everettg_99 at Jul 17, 2013, 04:01 PM
                  Sounds like maybe an environment issue -- are you running something like modSecurity or other firewall that may be blocking or otherwise filtering Ajax requests? Anything in your logs?

                  I was thinking about that. So I installed a fresh modx install in a dev directory on the server and everything was running great. So I'm assuming the hosting environment is fine(?).
                    Precision Web Development ... SmashStack.com
                    • 33982 ☆ A M B ☆
                    • 476 Posts
                    Quote from: BobRay at Jul 17, 2013, 11:08 PM
                    The message usually means that manager's request method has been called with an action that doesn't exist.

                    Look at the URL in the browser's address bar when you go to Security -> Manage Users and make a note of the action number. Typically, the URL would end with manager/?a=49.

                    In PhpMyAdmin, look at the modx_actions table (note: *not* modx_access_actions), you should see a record with the same Id with security/users in the action field. While you're there, try repairing all tables.

                    Assuming that you've tried manually deleting all files in the core/cache directory, clearing your browser cache and cookies, and turning off the compress_js and compress_css System Settings, I'd suspect either a corrupted DB table, or a corrupted or missing file in the install (especially if you transferred the files individually with FTP).


                    Thanks for that info. Will take another stab at the site today and go through those steps. Thanks!
                      Precision Web Development ... SmashStack.com