Hmm, looking at the code fail point its trying and failing to get a context from the new objects fields, try adding this line :-
$c->set(’context_key’, ’web’);
before your pagetitle set
Use MODx, or the cat gets it!
Sorry but i need to ask again, i thought the Problem would be solved but i get no error if i create newObject(’modResource’) as admin loged in all gone fine. But if i try the same script no logged in as admin i get the error from above. Hope someone of you has an idea.
Ok i think i got it now. Seems to be a user rights problem. After add right to the users i testet with it runs now. I hope this was the problem.
-
☆ A M B ☆
- 428 Posts
@cschimanski Thanks, five hours spent in vain, could not understand, why in one browser I can create a resource from front, and from another was not present. There was all in the rights of the user.
Valentin Rasulov - Industrial design (Hobbies - Web Development)
Development not standard projects on CMF MODx Revolution.
Small sample of extensions