-
☆ A M B ☆
- 3,141 Posts
Oh, that reminded me, there’s a system setting or config option somewhere to change the default permissions files and directories get. You may want to look into that to set it to a looser level to prevent you from being locked out all over again.
@Mark:
THanks for the ideas. To clarify, I am not having problems with the files/dir permissions, I mean the rwx(777) permissions, but with the server user permissions. I got access to the manager now (dont know what happened).
Your idea to erase the files from the manager did not work, I guess is the same permission denial, which is the problem because the OS is creating them with the nobody user as owner.
@paulp:
It is an account under my reseller account. So the host has root ownership, I (and my clients) have user permissions, but there is an intermediate Apache user named "nobody" which was "invented" so that files and directories created by web services will not be created with root ownership. So when MODX created files using PHP, the files are created by "nobody" and when I want to delete them, well I cant.
The host is very good and nice and are willing to change the permissions to me or delete the files for me,
but I want a more permanent solution instead of having them do that for me.
I will deal with the upgrade error, the Wayfinder error Mark, once I have solved the cache one, so I dont
start creating a huge snowball of problems...
Website: www.mercologia.com
MODX Revo Tutorials: www.modxperience.com
MODX Professional Partner
Thanks to all of you guys for your help and advice.
I have been scheduled to be moved to a server with suPHP
that will fix all these issues, I guess my server config
is old, around 4-5 years old and it will be a pain to
install in that server.
On the bright side, the server is newer and faster !!
Website: www.mercologia.com
MODX Revo Tutorials: www.modxperience.com
MODX Professional Partner
modx system must using ftp layer for create/copy/delete file like Joomla do