We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 29529
    • 34 Posts
    Upgraded from 2.0.8 to 2.1.1 and site will not load - it shows error 500

    MODx loads - but displays many line like this in the error log - and when clearing cache:

    [2011-06-04 16:50:45] (ERROR @ /index.php) Resource URI already exists for resource id = 10; skipping duplicate resource URI for resource id = 11
    [2011-06-04 16:50:45] (ERROR @ /index.php) Resource URI already exists for resource id = 10; skipping duplicate resource URI for resource id = 13
    [2011-06-04 16:50:45] (ERROR @ /index.php) Resource URI already exists for resource id = 10; skipping duplicate resource URI for resource id = 15
    [2011-06-04 16:50:45] (ERROR @ /index.php) Resource URI already exists for resource id = 10; skipping duplicate resource URI for resource id =

    I followed the instructions and upgrade went smoothly . . .

    Any suggestions on what to try next?

    Thanks!

    Terry

      • 3749
      • 24,544 Posts
      Manually delete all the files in the core/cache directory, then clear your browser cache and cookies.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 29529
        • 34 Posts
        Removed all files under core/cache and cleared browser cache and cookies - but no change.

        Still get those errors and site still giving 500 error.

        Any more thoughts on what I could try next?

        Thanks!

        Terry
          • 3749
          • 24,544 Posts
          Two things come to mind:

          1. Some of the older files didn’t get overwritten -- this can happen, especially if you use FTP for upload the files.

          2. One or more files was corrupted or lost in the download or upload. It happens more often than you might think.

          You did run Setup after installing the new files, right?
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 34022 ☆ A M B ☆
            • 91 Posts
            If re-uploading the files/ re-running the installer doesn’t help, try turning off friendly URLs. I had a similar error code once during the 2.1-RC period, and that fixed my problem.

            The error was caused by some of my resources having the same or empty alias - so make sure you give each one a unique alias (and of course check resource aliases 10, 11, 13, 15...).

            If that doesn’t do the trick, you may also want to set your homepage template to none (0) and delete any page content temporarily to see if a snippet is the problem.
              WebsiteZen.com - MODX and E-Commerce web development in the San Francisco Bay Area
              • 29529
              • 34 Posts
              No luck yet . . .

              I’ve uploaded the files again and run setup - which shows no errors.

              But site still won’t load - shows a 500 error

              Error log and Clear Cache show a couple of dozen errors like this:

              [2011-06-05 09:25:58] (ERROR @ /index.php) Resource URI already exists for resource id = 10; skipping duplicate resource URI for resource id = 11

              And, indeed, if I turn off Friendly Urls, these go away - but the site still won’t load.

              I think it’s time to get a pro involved. Can anyone suggest a MODx pro who could take a look at this?

              Thanks!

              Terry




                • 31088
                • 14 Posts
                Hi,

                OK, although I’m not sure what might be causing the larger issues, I did have the same cache problem.
                I was able to get past that by going to each resource mentioned in the error message - in the case of the one you listed below, `10`, and turning off "cacheable", and saving it, then doing the "clear cache" again and doing the next one. You could do it faster by doing it with a query.
                Once I had done that to all of the cacheable resources, and cleared the cache, it worked.

                This was after an upgrade from 2.08 to 2.11, like you.
                  • 29529
                  • 34 Posts
                  After clean install and setup now getting this error:

                  PHP Fatal error: Call to undefined method modX::getDocument() in /var/www/html/core/cache/includes/elements/modsnippet/74.include.cache.php on line 102

                  Anyone have any suggestions on how to deal with that?

                  Thanks, Terry
                    • 29529
                    • 34 Posts
                    Problem seems to be that the site has been infected by a script apparently known as “WebShell by oRB” which exploits a vulnerability in phpThumb.

                    See: http://www.htmlcenter.com/blog/webshell-hack-an-update/

                    Does MODx uses phpThumb? If so, can it be removed?

                    Thanks, Terry



                      • 29529
                      • 34 Posts
                      OK! Site finally up again.

                      Final hurdle required removing the MetaX snippet which was causing this fatal error:

                      PHP Fatal error: Call to undefined method modX::getDocument() in /var/www/html/core/cache/includes/elements/modsnippet/74.include.cache.php

                      Still have this problem

                      Resource URI already exists for resource id = 10; skipping duplicate resource URI for resource id = 55

                      But that can wait.

                      Thanks for your help

                      Terry