We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36502 ☆ A M B ☆
    • 491 Posts
    Hi,
    I followed the usual procedure to upgrade from 2.1 to 2.1.1, I’m using the advanced distribution.

    After upgrading the site is working fine but the manager:
    - doesn’t display left column
    - hangs up while cleaning cache
    - doesn’t let me log out
    and so on...

    if I give a look at the Apache log I found errors like this:

    [Fri Jun 03 12:13:45 2011] [error] [client ::1] File does not exist: /var/www/my_website/my_admin_folder/undefinedsystem, referer: http://localhost/my_website/my_admin_folder/?a=57

    What can I do?...
    Thanks,
    Alessandro
      TilliLab | MODX Ambassador
      website
      • 22303 MODX Staff
      • 10,725 Posts
      Sounds like you did not make sure all the files that needed to be overwritten by the advanced install were writable by the PHP process.
        • 36502 ☆ A M B ☆
        • 491 Posts
        Solved!

        I changed recursively the owner of all files to www-data and it went fine,
        thank you!
          TilliLab | MODX Ambassador
          website
          • 36502 ☆ A M B ☆
          • 491 Posts
          Hi,

          I used this command from the shell:

          sudo chown www-data:www-data yourModxFolder/ -R

          let me know if it works...



            TilliLab | MODX Ambassador
            website
            • 22286
            • 9 Posts
            I am experiencing this exact problem: no left panel, cache freezes, log outs fail. PHP 5.3.4, Mysql 5.5.13 on FreeBSD 8.2 w/ Advanced OR Traditional. Firefox 5 w/cleared cache and cookies. Nginx 1.0.4. Tried flushing core/cache as well.

            Directory is totally recursively chowned by www prior to setup. I’ve even tried chmodding everything to 777 but nothing seems to help.

            Seeing the same errors reported about undefinedsystem in the urls. I have rolled my site back to a backup.

            Where do I go from here?
              • 1892
              • 82 Posts
              Just posted a potential solution in this thread
              http://modxcms.com/forums/index.php/topic,65649.msg374176.html#msg374176

              Regards

              Adrian