We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 2048
    • 15 Posts
    Ok it is really Babel add-on the gulty ...

    i have found a temporary fix , modify Babel css ( /assets/components/babel/css/babel.css)

    #babel-box{
    	background:#ccc;
    	margin:15px 0 0;
    	padding:10px;
    	-moz-border-radius: 4px;
    	border-radius: 4px;
    	display: inline-block;
        padding: 5px;
        position: fixed;
        right: 160px;
        top: 120px;
        z-index:20;
    
    }
    

    think it is rely on http://modxcms.com/forums/index.php/topic,65123.0.html

    and as lossendae explain here : http://bugs.modx.com/issues/4656
      coding Java Android and NDS
      • 18373 ☆ A M B ☆
      • 3,141 Posts
      Could you file that here if it wasn’t yet? https://github.com/mikrobi/babel/issues
        Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

        Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
        • 2048
        • 15 Posts
          coding Java Android and NDS
          • 28120
          • 380 Posts
          Babel might be a red herring for me because this didn’t work before Babel was installed. I only intalled/uninstalled Babel to see if this would ’shift’ something.

          Maybe this issue is unrelated because I can’t get TinyMCE to work at all on this migrated site.
            • 18373 ☆ A M B ☆
            • 3,141 Posts
            Quote from: sparkyhd at Jun 10, 2011, 03:48 PM

            I’ve got the same problem. I’ve even tried installing / uninstalling babel to no avail?

            I’ve got this in the log but don’t know if it’s related

             [2011-06-10 20:44:32] (ERROR @ /adapt/connectors/resource/index.php) Error caching lexicon topic lexicon/en/core/resource
            [2011-06-10 20:49:10] (ERROR @ /adapt/connectors/system/rte.php) Error caching script elements/modplugin/1
            


            and the following errors on upgrade

            Error updating table for class modUserGroup
            Array
            (
            [0] => 42S21
            [1] => 1060
            [2] => Duplicate column name 'rank'
            )
            
            Error updating table for class modUserGroup
            Array
            (
            [0] => 42000
            [1] => 1061
            [2] => Duplicate key name 'rank'
            )
            


            Don’t worry about those errors on upgrade - that’s just to make sure your table has the latest added table names.


            The cache errors seem more serious - is your core/cache folder writable?
              Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

              Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
              • 28120
              • 380 Posts
              Yes - it was run on a WAMP server - everything’s writable
                • 28120
                • 380 Posts
                Actually what I’d failed to mention is that in addition to performing an upgrade from 2.08 to 2.1.1 I’d also transferred server.

                I wanted to test the upgrade on a local WAMP server before applying it to the live site.

                I just transferred the server again but not yet upgraded from 2.08 to 2.1.1 and my TinyMCE has gone missing in 2.08 on WAMP - I can’t see the toggle box. I can’t get TinyMCE to load at all.

                I’ve now solved this by


                • Running setup again in the same environment but choosing NEW instead of UPGRADE
                • Using a new database prefix
                • Discovering that TinyMCE works fine in a fresh install
                • Editing config.inc.php back to the original database prefix (is this safe/legitimate?)

                Also while hunting around for a rogue path I did notice most of the packages (not TinyMCE) have a file ’preserved.php’ with paths for the old server - should these be updated when migrating?
                  • 36225
                  • 20 Posts
                  Hi all,

                  I had a similar problem: no TinyMCE but only textareas instead, and no toggle editor checkbox.
                  After trying all what you’ve mentioned (clear cache, update to the latest TinyMCE, running setup again with a new database prefix) and no sucess, I’ve noticed that I did get JS errors, and this leads me to the fact that I’ve moved my whole modx to another directory and forgotten to update the assets URL path in the core/config/config.inc.php:

                  $modx_assets_url= ’/my/new/directory/assets/’;

                  Hope this helps.