We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 35714
    • 4 Posts
    Hi there,

    I installed the latest Revo-Release 2.1.1 on two accounts of one server. Everything went fine, but since a few days, the backend doesn’t display properly anymore. I can log in without any problems, but the manager doesn’t display the window on the left where you edit documents, ressources, templates and so on. Most pages of the manager are empty (system -> system settings for example), some others like user administration appear broken (view attachment).

    Due to the fact I didn’t change anything in the code or the database, I cannot really tell where this comes from. I supposed maybe my hosting company changed something in PHP or MySQL-Software, but apparently they didn’t. PHP-Debug doesn’t show anything, setting memory_limit to 128MB didn’t help either.

    If you need any more information, just ask.

    Thank you!

    Ah yeah...

    Modx Revo 2.1.1 Traditional
    Server: Linux webbox444 2.6.32-32-server #62-Ubuntu SMP Wed Apr 20 22:07:43 UTC 2011 x86_64
    PHP Version is 5.2.16
    MySQL is 5.1.41 (Client)
    pdo_mysql: PDO Driver for MySQL, client library version 5.1.41
    Browser: tried Firefox and Safari, latest versions
      • 1343 ☆ A M B ☆
      • 2,213 Posts
      I have seen this problem before, you just need to replace the manager and connector folders with ones from a fresh install.

      I don’t know why this happens, but that should fix it for you. smiley
        Patrick | Server Wrangler
        About Me: Website | Tweets |  MODX Hosting
        • 35714
        • 4 Posts
        Thanks for the help, but unfortunately it still doesn’t work...meanwhile I even tried deleting all folders and database-tables and to install ModX again on several accounts, but that also doesn’t work. I’m getting a little desperate... undecided
          • 1343 ☆ A M B ☆
          • 2,213 Posts
          I would be happy to take a look for you. Email the details to [email protected]
            Patrick | Server Wrangler
            About Me: Website | Tweets |  MODX Hosting
            • 35714
            • 4 Posts
            We couldn’t solve the problem...now I tried to install ModX Evolution (latest release) and it works fine. But ModX Revo still doesn’t work, neither 2.1.1 nor 2.1.2. Anybody has a explanation why Evo works and Revo doesn’t?
              • 18373 ☆ A M B ☆
              • 3,141 Posts
              They’re two different products and besides sharing the same paradigms under the hood they are very, very different..

              If Patrick couldn’t pull it off I doubt I can help you via the forum though I am curious what can be going on. I’ll just copy his suggestion - email me some details to business -at- markhamstra.nl.
                Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                • 35714
                • 4 Posts
                Finally we found out what the problem was. The server didn’t parse .js.php files, so the backend couldn’t work with these files and was not able to display documents, settings and so on.

                Solution: Create a .htaccess in your main folder with this content:

                RemoveType .php
                AddHandler x-httpd-php53 .php
                AddHandler x-httpd-php53 .js.php

                Now everything seems to be working fine again. Thank you so much for your help!
                  • 18373 ☆ A M B ☆
                  • 3,141 Posts
                  Just to add a bit to help others find out if they have a similar problem...

                  - There were no 404 requests when loading the manager home screen, but javascript errors indicate the "MODx" (or sub-)variable is undefined.
                  - Upon trying to open a .js.php file (the config is one of them, and the culprit in this case) instead of outputting the content it pops up a download box allowing you to download the php source.
                    Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                    Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                    • 22835
                    • 54 Posts
                    I've just started to have some display issues with my install 2.2.1 revo, php 5.2.16

                    The buttons above the resources tree left hand side and the "save", "close" buttons top left are appearing broken. They're functionally working it's just a display issue.

                    See the image attached.

                    The above fix:
                    htaccess - so i can change the modx ht.access to a .htaccess file but how do i insert/create the code phil87 mentions?
                      • 22835
                      • 54 Posts
                      I've just had a look through the error log and the following error is registered just as my manager display errors started to happen.

                      [2012-05-09 00:24:48] (ERROR @ /connectors/element/propertyset.php) Error caching lexicon topic lexicon/en/core/default 


                      "caching lexicon"
                      what does this mean?