We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 34000
    • 77 Posts
    Set up a new installation today, and attempted to download components, GetResources and Blogging Essentials.
    Next when trying to install Blogging Essentials, the pop-up modal window seemed to just hang.
    To close that window, the only way I could think how I just entered the url in the browser bar to get to the homepage for my manager. this returned a 500 Internal Server Error.
    What to do to return to my manager page, or see anything other than the 500 error?
    :’(
      MODx Revo 2.1 and done!
      • 34000
      • 77 Posts
      Now my host informs me he switched things from ISAPI to CGI/fastCGI, sor tof blew me away since I thought that was what it was all along, and why I host with them.
      So today’s error is at the manager log-in screen, thought all was going to be well.
      But instead of logging me in after entering the credentials, I get this:
      ------------
      405 - HTTP verb used to access this page is not allowed.
      The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.
      -----------

      I sure hope I can iron out the bugs, I was afraid maybe trying to use the control panel manager’s download packages was giving me permissions problems or something, speculating though. Off to google a new error message sad
        MODx Revo 2.1 and done!
        • 34000
        • 77 Posts
        I found this answer, that says something about adding a trailing slash to a redirect someplace or other.
        Does that sound like something I can adjust someplace?
        http://stackoverflow.com/questions/1400210/what-causes-an-http-405-invalid-method-http-verb-error-when-posting-a-form-to
        Just the first thing that came up on google.

        Further attempts at logging in and the log-in page does not load correctly only the body id=login form parts.
        i’m afraid to enter the credentials now in fear of the 500 internal server point of doom.
          MODx Revo 2.1 and done!
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          Try clearing your browser cache and cookies, then try logging in again. If the hosting tech support was fiddling with server configurations, it may be that your browser was caught in the middle and is still trying to access the old configuration.
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 34000
            • 77 Posts
            It seems like @palanthus is hot on the trail for this one here in the forums:
            http://modxcms.com/forums/index.php/topic,57360.0.html
            I even have Plesk control panel, maybe this will be spot on.
              MODx Revo 2.1 and done!
              • 34000
              • 77 Posts
              Thanks Susan, I’ll try, not sure it’s the cache, beings I tried IE7 even as an alternative browser, and I doubt I accessed the site in that, if you know what I mean wink
              Got my fingers crossed & my mind open... either way.
                MODx Revo 2.1 and done!
                • 34000
                • 77 Posts
                Hmm... if my host switched to FastCGI after I installed revo yesterday, would it cause any quirks with this install? Man I’ld hate to have to reinstall again.
                  MODx Revo 2.1 and done!
                  • 34000
                  • 77 Posts
                  I found another suggestion, might of been a good one, and an easy fix.
                  My default document was not set to index.php for directories.
                  changed that in the Plesk control panel for my domain under Domain |Web Directories |DIrectory Properties...
                  And moved Index.php up in the default documents order list.
                  Hoping it’s a fix undecided

                  Nope still not it, but changing that one was maybe a good idea still... sad
                    MODx Revo 2.1 and done!
                    • 22303 MODX Staff
                    • 10,725 Posts
                    If your host changed from one method to another, they probably also changed the user PHP is running as. In that case, all the files that were writable by the PHP process may no longer be. If you still have the setup directory in place, you can run setup in upgrade mode and it should notify you of problems with writing to the directories it needs to.
                      • 34000
                      • 77 Posts
                      The setup directory is gone.
                      Can I just upload the setup directory, and try running upgrade.
                      Worth a shot?
                        MODx Revo 2.1 and done!