We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3112
    • 11 Posts
    Running ModX Revo 2.0.8 and the site became unresponsive. looking at the Apache logs I see PHP Fatal error: Allowed memory size of 134217728 bytes exhausted in modresource.class.php

    In the manager the resource document tree will not display, I see the web context no documents unless I create a new one. I see the pages in the MySQL DB. I am thinking the id’s might be messed up, however I did not input the content so not sure.

    ModX running Apache/2.2.17 PHP/5.3.5 FreeBSD in a VMWare guest.

    Thanks for any input.
      • 3749
      • 24,544 Posts
      Try these steps (do all of them in order, without testing in between):

      Log out of the Manager.
      Manually delete all files in the core/cache directory.
      Clear your browser cache *and* cookies.
      Run Setup (again).

      If that doesn’t do it, go into PhpMyAdmin in cPanel and try repairing the tables in the DB.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 3112
        • 11 Posts
        I did the things in the list, still no documents showing. I am thinking it could be a ACL permissions issue. As I can create new pages and they show up fine. Is there a way to reset all permissions back to defaults?

        Any suggestions welcome.
          • 3749
          • 24,544 Posts
          Did you create ACL entries? If so, that may be part of your problem.

          There’s no revert to default option, but the only default entries are the first two Context Access ones for the Administrator group (and possibly one for the (anonymous) group.

          Your problem would most likely be caused by one or more Resource Group Access ACL entries. There are none of these in the default install.

          Also, make sure you have an error page (error_page System Setting), and that it is published.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 1343 ☆ A M B ☆
            • 2,213 Posts
            How much memory do you have allotted in your php.ini file?
              Patrick | Server Wrangler
              About Me: Website | Tweets |  MODX Hosting
              • 3112
              • 11 Posts
              memory_limit = 128M
                • 3112
                • 11 Posts
                I think it has to do with the site_content table. I restored an old backup and it works fine. when I replace the site_content table with the newer content modx will not display the documents again. If I try to create a new document I get a 500 server error.
                  • 3112
                  • 11 Posts
                  if i try to create a new page apache logs: PHP Fatal error: Call to undefined method modX::isFrontend() in /usr/local/httpd/core/cache/includes/elements/modplugin/1.include.cache.php on line 33
                    • 3749
                    • 24,544 Posts
                    The plugin with ID 1 contains a deprecated function (TinyMCE?). See if there is an update.

                    If it’s TinyMCE, I’d recommend uninstalling and removing the old version before downloading the new one.
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                      • 3112
                      • 11 Posts
                      Thanks, that fixed the page creation problem, still cannot see pages in the tree.