Short story:
A long time ago... Russian member Akots found a bug in 0.9x versions. Lucky bug travels through all versions of evolution, and now our mission is to fix it before 1.1 release.
About bug:
If you running with mysql strict mode on, and your manager language is not english (it can be english too, but you need many words in language variables) you’ll receive MODx parse error when config_check file checks your config

Why? Because this file adds to DB (source field) full text of error (text from language variable). If you look at type of source field you’ll see who is responsible for bug. And mr. Who is varchar(50) !
So, Russian language variables with error text sometimes bigger than 50.
Quick fix:
Replace all db inserts with short word, "Config check" for example. But log will be less informative.
Or change table properties. I don’t like this one.
I prefer refactoring.
Why refactoring?
1. Bad internationalized log. For example, by default we have English language selected in manager. And also we have Chinese or Japanese or any other non english Moderator. But admin is english guy. And what happens if Japanese moderator will generate an error? Yes! Source field will be in Japanese =)
To recognize, what kind of error it is, english admin must look at language variable and compare it with english one. Not good huh?
We have Source and Description fields.
I think that source field must contain SOURCE of an error. Not description.
Source must contain source.
Description must contain language variable or id to be language independent.
And I think we need to add new field for source code to store PHP and Mysql errors.
2. Not informative. We have table with Event id. Does it make sense? Can you say by number what user trying to do without look in source code? No. (yes, if you are know every bit of modx core). ID must have an alt text that describes what is going on.
3. Error in mysql strict mode.
This is my thoughts. Just want to make MODx better.
Screenshot describes some aspects.
UPDATE. Example of error added
« MODx Parse Error »
MODx encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Data too long for column 'source' at row 1 »
SQL: INSERT INTO `modx103clear`.`modx_event_log` (eventid,type,createdon,source,description,user) VALUES(0,2,1272250201,'Не удалена папка с файлами, использовавшимися в процессе установки','Папка /install содержит инсталляционные файлы системы MODx. Злоумышленники могут воспользоваться этими файлами для взлома/повреждения сайта, так что лучше удалить папку с сервера.','1')
UPDATE2. Not best solution which provided by Akots. (one of the best and fast for 1.0.4)
Replace all these strings
$modx->logEvent(0,2,$warnings[$i][1],$_lang['configcheck_configinc']);
$modx->logEvent(0,2,$warnings[$i][1],$_lang['configcheck_installer']);
$modx->logEvent(0,2,$warnings[$i][1],$_lang['configcheck_cache']);
$modx->logEvent(0,2,$warnings[$i][1],$_lang['configcheck_images']);
With this one
$modx->logEvent(0,2,$warnings[$i][1],'Config Check');
This solve problem, but log will be less informative, because description contains only full text of error. Short description will gone. (Or we can add short description with long in one field)