We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3749
    • 24,544 Posts
    I’ve upgraded my XAMPP install but I’m still getting fairly regular crashes of Apache when I save a snippet or chunk (I haven’t been saving many resources so I don’t know if that would do it too).

    Here’s the current setup:

    Vista Ultimate SP1
    Apache 2.2.9
    Php 5.2.6
    MySQL
    Client API Lib Version 5.0.67
    Client API Header Version 5.0.51a

    Apache shuts down, then restarts and I’m almost always able to continue work in the manager.

    Ironically, I can’t shut down Apache myself, even after a reboot, so it’s hard to look at the Apache error log. I finally got at it from the command prompt. The only thing of note in the Appache error log is:

    [Sun Nov 02 12:41:32 2008] [notice] Parent: child process exited with status 255 -- Restarting
    And there’s an entry from ten seconds earlier in the MODx error log:

    [2008-11-02 12:41:22] (ERROR @ /modx097/connectors/element/chunk.php) Could not write file C:/xampp/htdocs/MODx097/core/cache/lexicon/en/core/default.cache.php
    That chunk.php file is only two lines long:
    require_once dirname(dirname(__FILE__)).'/index.php';
    $modx->request->handleRequest('element/chunk');


    Searching suggests that this is an out of memory error, though people who are clearly not out of memory still get it. One author found it was caused by a circular script reference.

    This only happens when I save in the Manager (but not every time), my site and snippets run fine.

    So far, it’s happening in IE7. I haven’t used FF enough lately to know if it happens there.

    I don’t know if it’s relevant, but looking at the Revolution code it appears that the handleRequest() function that’s being called (the one in the modrequest class) takes no arguments, although there are many calls to it that supply one in addition to this one. There is a handleRequest() function in the modConnectorRequest class that takes two optional arguments.
      Did I help you? Buy me a beer
      Get my Book: MODX:The Official Guide
      MODX info for everyone: http://bobsguides.com/modx.html
      My MODX Extras
      Bob's Guides is now hosted at A2 MODX Hosting
      • 3749
      • 24,544 Posts
      I’ve been saving a lot in FF3 and can’t seem to make this happen, so maybe it’s another (ugh) IE7 problem.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 22303 MODX Staff
        • 10,725 Posts
        I can’t replicate this on my XP environment with XAMPP 1.6.8 for Windows. Anyone else seeing this Apache behavior when working with the latest builds of Revo alpha?
          • 3749
          • 24,544 Posts
          It could be Vista or my particular Apache setup, although, I think it’s the default XAMPP setup and I don’t know why it wouldn’t also affect FF3.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting