We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3749
    • 24,544 Posts
    I got the lexicon management screen but then a message from Apache saying it was shutting down (actually got this twice).

    I was on r4242, I think, so this may no longer be relevant, but I thought I’d post the Apache error log here.

    [Mon Oct 06 17:48:34 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Mon Oct 06 17:48:35 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
    [Mon Oct 06 17:48:35 2008] [notice] Server built: Jan 18 2008 00:37:19
    [Mon Oct 06 17:48:35 2008] [notice] Parent: Created child process 540
    [Mon Oct 06 17:48:36 2008] [notice] Child 540: Child process is running
    [Mon Oct 06 17:48:36 2008] [notice] Child 540: Acquired the start mutex.
    [Mon Oct 06 17:48:36 2008] [notice] Child 540: Starting 250 worker threads.
    [Mon Oct 06 17:48:36 2008] [notice] Child 540: Starting thread to listen on port 443.
    [Mon Oct 06 17:48:36 2008] [notice] Child 540: Starting thread to listen on port 80.
    [Mon Oct 06 17:48:58 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/MODx097/manager/assets/modext/util/filetree/ext, referer: http://localhost/modx097/manager/index.php?id=0
    [Mon Oct 06 17:49:20 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/MODx097/manager/assets/modext/util/filetree/ext, referer: http://localhost/modx097/manager/index.php?id=0
    [Mon Oct 06 17:55:12 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/MODx097/manager/assets/modext/util/filetree/ext, referer: http://localhost/modx097/manager/assets/modext/util/filetree/css/filetree.css
    [Mon Oct 06 18:00:09 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/MODx097/manager/assets/modext/util/filetree/ext, referer: http://localhost/modx097/manager/index.php?id=0
    [Mon Oct 06 18:00:29 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/MODx097/manager/assets/modext/util/filetree/ext, referer: http://localhost/modx097/manager/index.php?id=0
    [Mon Oct 06 18:04:08 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/MODx097/manager/assets/modext/util/filetree/ext, referer: http://localhost/modx097/manager/assets/modext/util/filetree/css/filetree.css
    [Mon Oct 06 18:04:29 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/MODx097/manager/assets/modext/util/filetree/ext, referer: http://localhost/modx097/manager/assets/modext/util/filetree/css/filetree.css
    [Mon Oct 06 18:13:15 2008] [notice] Parent: child process exited with status 255 -- Restarting.

      Did I help you? Buy me a beer
      Get my Book: MODX:The Official Guide
      MODX info for everyone: http://bobsguides.com/modx.html
      My MODX Extras
      Bob's Guides is now hosted at A2 MODX Hosting
      • 28215
      • 4,149 Posts
      Looks like your build might have messed up on install. Try a rebuild and upgrade-setup. If that doesn’t work, try a cache clearing. If that doesn’t work, well, get back to me. tongue
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 3749
        • 24,544 Posts
        Could be, although it worked fine for about a week on that build/install.

        Possibly my failed attempts to create a system setting messed something up.

        I’m upgraded to r4265 now so I’ll let you know if I see it again.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 3749
          • 24,544 Posts
          Had another Apache crash on manager login after update/build/install to r4275.

          Here’s the Apache error log

          [Thu Oct 09 16:04:52 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/MODx097/manager/assets/modext/util/filetree/ext, referer: http://localhost/modx097/manager/index.php?id=0
          [Thu Oct 09 16:05:11 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/MODx097/manager/assets/modext/util/filetree/ext, referer: http://localhost/modx097/manager/index.php?id=0

          There is no "ext" listed under manager/assets/modext/util/filetree in my install (or in the SVN repository) so the message is accurate, though why a missing file or directory would crash the server is a mystery.

          Also, I can’t find a reference to "modext/util/filetree/ext" anywhere in the .js or .php code. And I can’t find "modext/util/filetree" with a variable follwing it.


            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 22303 MODX Staff
            • 10,725 Posts
            Bob, what PHP, MySQL (client and server), and Apache versions? I doubt the shutdown is because of the missing file errors, or does it always happen when that is recorded?
              • 3749
              • 24,544 Posts
              I think it always happens on that error but I’m not sure. It’s only happened twice (maybe three times) over the last week or two.

              The fact that it happened once on login and once on selecting lexicon management should tell us something, but I’m not sure what. I think it may have happened once when I selected System Settings.

              It’s been solid for a long time until this started. It could be 5.0.51a, but I’ve been using it for a long time with no trouble. A lot of servers are still using it and, if MODx crashes Apache under it, we should probably know why.

              I think this configuration is all XAMPP 1.6.6a.

              PHP 5.2.5
              Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color (20051115)

              Loaded Modules: core mod_win32 mpm_winnt http_core mod_so mod_actions mod_alias mod_asis mod_auth_basic mod_authn_default mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_cgi mod_dav mod_dav_fs mod_dir mod_env mod_include mod_info mod_isapi util_ldap mod_log_config mod_mime mod_negotiation mod_rewrite mod_setenvif mod_status mod_ssl mod_autoindex_color mod_php5

              MySQL
              client API library: 5.0.51a (yeah, I know)
              client API header 5.0.45

              PDO driver 5.0.51a

                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 28042 ☆ A M B ☆
                • 24,524 Posts
                The version of the MySQL client does not necessarily reflect the version of the MySQL server. You can either look at the opening screen of phpMyAdmin to get the server version, or use a simple script with mysql_get_server_info(); or a snippet with $modx->db->getVersion() which does the same thing.
                  Studying MODX in the desert - http://sottwell.com
                  Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                  Join the Slack Community - http://modx.org
                  • 3749
                  • 24,544 Posts
                  I was looking at PhpInfo when I wrote that. I couldn’t find any entry for MySQL server, but my eyes aren’t what they used to be. wink

                  $modx->db->getVersion() says:

                  Fatal Error: Call to undefined method DBAPI::getVersion()

                  (So, I guess not in Revolution).

                  mysql_get_server_info() says the server version is also 5.0.51a.
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 22303 MODX Staff
                    • 10,725 Posts
                    I suspect the client and server API for MySQL being different here is part of the problem. I’ve run into similar environments with similar shutdowns when using PDO code. See if you can get PHP compiled against the proper MySQL client API for the server version being run and I bet all your problems go away.
                      • 28215
                      • 4,149 Posts
                      5.0.51a is a nightmare version. Lots of bugs all around.
                        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com