Sins I moved to a new server I do not get the errors that I normally get from snippets etc when I forgot a ; or a } i just get nothing.
I only get a error if its a real hard error and the template does not load
but errors on the place where the snippet is run stopped appearing
My server config is now this:
PHP Version 5.1.6
on centos Linux
I did disable some php settings for security reasons:
disable_functions = system,passthru,eval
maybe its the eval?
is it save to switch that on again?
Dimmy
Snippets are run with the eval() function in MODx 0.9.6
all snippets run fine until i make a typo in a snippet that i develop and then is see noting no error nothing
its hard to bug track when you get no feedback from the server that something is wrong
-
MODX Staff
- 10,725 Posts
Sounds like display_errors is off; there should be a log file capturing these errors if that is the case. Either the apache error log, or a custom error log that should be specified in the php configuration.
Thank you Jason that was indeed the problem setting that to "On"did the trick.
much easier bug tracking when you know where to look