We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22303 MODX Staff
    • 10,725 Posts
    Not sure if this is your issue TobyL, but let me requalify the statement to say "if you checked out the project from svn since I posted this topic..."

    Unfortunately, if you have an earlier test version checked out, you need to start from scratch, running the build script and executing it to create the tables. Quite a few things have been changing and we likely will not have proper 0.9.7-alpha-xxxx to 0.9.7-alpha-xxxx upgrades ready until after the first public release package is made available.

    @TobyL: what PHP and MySQL version are you running by chance?
      • 30223
      • 1,010 Posts
      I only checked it out (and installed it) less then 24 hours ago so I think ’an earlier test version’ might not apply in this case. However I found the problem was of my own making. While testing an unrelated site I disabled javascript in FF. Ignore my stupidity embarrassed embarrassed embarrassed

      Perhaps it would not be a bad idea to have a javascript test in there somewhere to alert idiots like me smiley

      Just for your info, my server setup is:
      * Apache/2.2.4 (Win32)
      * MySQL 5.0.41
      * PHP 5.2.3 with PDO, pdo_mysql extensions enabled


        • 7455
        • 2,204 Posts
        I installed revision 2914 all went ok until I tryed to login. i see the login screen i am able to enter user and pass but cliking on the submit button or pressing enter does not apear to do anything.

        my instalation is here:

        http://www.hilverda.eu/

        and how would you normaly get the inlog screen? typing /manager ore /core does not work I realyu need to type the whole index.ph.?&action=login thing?

        http://www.hilverda.eu/manager/index.php?action=login

        it gives an error saying e.succsess is empty or no object

        dimmy
          follow me on twitter: @dimmy01
          • 22303 MODX Staff
          • 10,725 Posts
          Dimmy: when I go to /manager I get the login page like I am supposed to, and I see the proper error message alerts (lightbox-style) when trying to login with random usernames and passwords. I guess it’s time for environment information from you, including the browser you are using.
            • 7455
            • 2,204 Posts
            firefox 2.0.0.6 and ie7 same results in ff i get the error:

            Error: syntax error
            Source: http://www.hilverda.eu/manager/media/script/ext/ext-all-debug.js
            Line: 6510, Kolom: 1

            on another pc ie7 I got to see the lightboxlike erro once then i got o 404 all the time. I cant get the login back.

            i need to restart ie7 to see the error again

            updat:
            when i type a wrong use/pass then i see the lightboxlike error but when user and pass are ok then i get nothing.
            en then i get a 404 if I try to refresh the page. i need to stop ie or ff and then it works again.

            looks like it has somthing to do with sessions? use this to login (well try to) admin/modxtest

            Dimmy
              follow me on twitter: @dimmy01
              • 22303 MODX Staff
              • 10,725 Posts
              Very odd Dimmy. Can you send me your core/cache/logs/error.log file to review? Something very odd going on with sessions there for sure.

              Also, can you let me know what PHP version, MySQL version, and if PHP 5.x, whether or not the PDO MySQL driver is enabled?
                • 7455
                • 2,204 Posts
                apache 1.3.31
                MySQL 4.1.15-standard
                php 4.3.2-26.ent.1.swsoft

                I could give you full acces to that domain if you want including bin/bash , ftp and plesk.

                Dimmy
                  follow me on twitter: @dimmy01
                  • 22303 MODX Staff
                  • 10,725 Posts
                  Wow, that 4.3.2 may be the problem. undecided

                  I really just need to see the error.log file if possible, and if nothing obvious stands out, I may get you to turn debugging mode on, so we can see all PHP errors and get a ton of output showing what’s really going on.

                  UPDATE:
                  Bingo! http://www.php.net/manual/en/function.session-regenerate-id.php -- I just added use of this function in the modUser class (core/model/modx/moduser.class.php) in the function addSessionContext(). It seems that this does not automatically reset the session cookie until 4.3.3. Try just commenting out the block of code that looks like this:
                  <?php
                          $oldSessionId= session_id();
                          session_regenerate_id();
                          //HACK: Removing the old session object from the database so it can't be hijacked.
                          if ($oldSession= $this->xpdo->getObject('modSession', array ('id' => $oldSessionId), false)) {
                              $oldSession->remove();
                          }
                  ?>
                  and see if that helps you get logged in.

                  I’ll likely be moving this hack, (cough) logic out of here and force the session handler to deal with it anyway.
                    • 7455
                    • 2,204 Posts
                    ok login works now but the manager interface looks a bid odd. only the toolbar is renderd and I get this javascript error:

                    Fout: modTree is not defined
                    Bronbestand: http://www.hilverda.eu/manager/media/script/modext/tree/modnavtree.class.js
                    Regel: 11

                    Fout: modNavTree.superclass has no properties
                    Bronbestand: http://www.hilverda.eu/manager/media/script/modext/tree/modnavtree.class.js
                    Regel: 9

                    in ie7 and ff I get the same results
                      follow me on twitter: @dimmy01
                      • 28215
                      • 4,149 Posts
                      Quote from: Dimmy at Sep 16, 2007, 02:32 AM

                      ok login works now but the manager interface looks a bid odd. only the toolbar is renderd and I get this javascript error:

                      Fout: modTree is not defined
                      Bronbestand: http://www.hilverda.eu/manager/media/script/modext/tree/modnavtree.class.js
                      Regel: 11

                      Fout: modNavTree.superclass has no properties
                      Bronbestand: http://www.hilverda.eu/manager/media/script/modext/tree/modnavtree.class.js
                      Regel: 9

                      in ie7 and ff I get the same results

                      Dimmy,

                      So, I checked to see if those files even existed...

                      and I get a 404 when I try to load http://www.hilverda.eu/manager/media/script/modext/tree/modtree.class.js
                      into the browser.

                      Is that file uploaded? If so, is the .htaccess file in /manager/ active so that it turns RewriteEngine Off?
                        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com