Well yes and no. The db is being written to, because the error is recorded in the MODx event_log. I think that perhaps it’s only when there is a lot of data to write that the db was choking, and that may be due to a disk problem on the server or a configuration error (or maybe not).
When you explain it that way it makes sense that this could be the same error just not being triggered as frequently, so I’ll assume that’s the case and see what happens with 0.9.6 (you’re right that the worst-case scenario is hard-coding base_url and site_url, so that’s no biggie).
As an aside, did fixing this error mean that the Template Switcher Plugin is now officially out of the dog house? Someone in the forums was insisting on using it, and I wasn’t sure how risky this was in the latest version. I actually have a 0.9.2.2 site that also uses that plugin which I haven’t updated for that reason, so if it’s now possible I may do so.
I upgraded this site to 0.9.6 RC2 a few days ago, and unfortunately the MySQL Error 28’s just keep on coming. There were about a dozen or so in the System Events log yesterday, but today there were hundreds. Even one is too many, so we’re going to have our host move this account to a different server to see if that helps.
I have many other 0.9.5 and 0.9.6 sites with this same host, and none of them has ever thrown an Error 28 as far as I know. The only thing that stands out about this particular site in my mind is that it uses lots of Ditto calls (Ditto 2 RC3). I don’t know why that (or anything really) should cause this error, but it might mean more database queries than usual are being attempted anyway.
Any other ideas as to why this site might be bugging out? It might just be an overstressed database server. But if moving to a different one doesn’t resolve the problem, I’m not sure what to try next.
It is a shared server, so my current working assumption is that either some other account on this machine is overusing it or this particular database server has a problem of some kind (hardware or setup).
We have about 15 or 20 MODx sites on this same host, and we’ve never had anything like this happen before.
Oddly, we haven’t had any errors today, nor did we for a couple days after I did the upgrade (which made me think that had fixed it).
-
MODX Staff
- 12,272 Posts
Sounds very much like there’s another person on the box nailing the DB periodically.
Ryan Thrash, MODX Co-Founder
Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
Curiouser and curiouser...
OK so the host wrote back to us that "the issue with the database server for this account appear to have been corrected." They didn’t explain what they did, but in fact that account has been free of any error since before they were working on it. So that’s all good, and lends credence to the idea that it was a specific problem on this machine.
However, I just noticed that a DIFFERENT 0.9.5 installation on a completely separate machine (although with the same host) also registered a couple Error 28s in the last few weeks. It was only two (compared to hundreds on the original account), but nevertheless I find that odd because I’d never seen these before. So now I’m wondering whether the host is having database server issues in general, or there’s some sort of background MySQL worm or attack going on that could be related, or there was/is in fact a sporadic error in some post-0.9.5 versions of MODx that are causing this.
Am I still the only one who’s had these errors show up in their System Events log? If so, then it’s probably related to my host. But if not, then we may need to track this down.
So far it sounds like it’s just me, but I thought I’d ask again and see if anyone else responds...
one thing I did had was an overhead of 3 Gig on the manager.events table. I had this on 3 modx instalations where we dit a lot of work inside the manager like creating losts of custoom snippets and editing them creating documents etc.