We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22303 MODX Staff
    • 10,725 Posts
    Quote from: heliotrope at Jan 24, 2007, 12:43 PM

    Jason ,

    that’s the only snippet call in the page (template set to blank)

    :-)
    Hmmm, didn’t try it with a blank template, but not sure why that wouldn’t work, as the eForm tags work with embedded tags, hmmmm...please try it with non-cachable tags [[!ditto? ... &startId=`[[UltimateParent]]` ]] and see what happens...
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Is 2261 totally unusable at this point? I got it installed with only two items not installed (a plugin and Jot tpl files not in the install folder) but there is something about a yearSkew not defined causing all kinds of hate and discontent when trying to log in to the Manager. The front-end seems OK.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 22303 MODX Staff
        • 10,725 Posts
        Quote from: sottwell at Feb 01, 2007, 04:39 AM

        Is 2261 totally unusable at this point? I got it installed with only two items not installed (a plugin and Jot tpl files not in the install folder) but there is something about a yearSkew not defined causing all kinds of hate and discontent when trying to log in to the Manager. The front-end seems OK.
        Never seen anything like this...can you provide more details on this problem?
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          The browser shows a long list of error messages, beginning with
          Notice: Undefined variable: yearSkew in
          /Applications/MAMP/htdocs/modx097alpha2267/core/xpdo/om/mysql/xpdoobject.class.php
          on line 1533
          then a whole bunch of issues with "headers already sent" due to that notice.

          However, it does process the login, so going to the manager again works fine. It’s just that notice hanging things because of the headers for the notice being sent.

          Ah, missed this... I get another one
          Notice: Undefined variable: cookieLifetime in
          ... modx.class.php
          on line 2011

          Another notice about sessions already started on modx.class.php on line 2006... I guess my problem is my php is set to display notices.
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            I find the setDebug function, with its $stopOnNotice argument:
                function setDebug($debug= true, $stopOnNotice= false) {
                    $oldValue= $this->getDebug();
                    if ($debug === true) {
                        error_reporting(E_ALL);
                        parent :: setDebug(true);
                    } elseif ($debug === false) {
                        error_reporting(0);
                        parent :: setDebug(false);
                    } else {
                        error_reporting(intval($debug));
                        parent :: setDebug(intval($debug));
                    }
                    $this->stopOnNotice= $stopOnNotice;
                    return $oldValue;
                }

              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 28215
              • 4,149 Posts
              After completing a fresh install, clicked the ’close’ button to proceed to manager, and this error occured:

              Warning: strtotime() [function.strtotime]: Called with an empty time parameter. in /Web_Server/modxdev/core/xpdo/om/mysql/xpdoobject.class.php on line 1532

              ...and a blank page. Had a couple other issues, which I reported in flyspray, but neither of those are critical.

              Side Note:
              After doing a little debugging, i found the exact time/line of the error occuring, in an odd place:
              It happens when $modx->initialize(’web’) is run, and in modx.class.php on like 2008...the session_start(); command. Is there a reason that starting the session would cause a strtotime error? If I change the line to:

              @session_start();, then the error doesn’t occur, and the manager loads fine.

              Server info:
              Mac OS X 10.4.8
              MySQL 4.1.7-log
              Apache/1.3.33 (Darwin)
              PHP/5.0.5
              mod_ssl/2.8.24
              OpenSSL/0.9.7l
                shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                • 22303 MODX Staff
                • 10,725 Posts
                I found the problem in my xPDOObject::set() method when working with ’timestamp’ values mapped to numeric database values. I’m not treating the values properly and end up sending an ’empty’ time parameter to strtotime(). I’ll work on this later today and get it checked in. Just curious why that error shows up for you but not for me... :/

                In any case, you can alternately just empty the configuration setting for session_handler_class and it will bypass the database-managed session handler which is triggering that error.
                  • 27376
                  • 576 Posts
                  Here’s my notes on this revision as I upgrade from 0.9.5.1-RC1 (rev 2258)

                  Install Process
                  Two snippets/plugins were not upgraded:

                  • /modx-0.9.7-alpha/install/plugin.searchhighlight.tpl’ not found.
                  • /modx-0.9.7-alpha/install/snippet.jot.tpl’ not found.
                  Installation Successful

                  Manager Login
                  Manager Login Successful
                  Save System Settings Successful

                  Preview Site

                  • Warning: Illegal offset type in [...]/core/xpdo/om/modx095/modx.class.php on line 404
                  Warning line appears a large number of times, page refreshes, displays same error message.

                  I found the issue to be the SEO Strict URLs Plugin v0.7.2. Page loads after disabling the plugin.

                  I have it working!

                  PHP Version 4.4.1
                  Apache 1.3
                  PDO not installed :-/

                  Anyone know of a place where I can download PDO for php 4? I’ve found where to download the PDO extension but it requires PHP 5...
                    • 22303 MODX Staff
                    • 10,725 Posts
                    Quote from: sirlancelot at Feb 16, 2007, 05:02 PM

                    Anyone know of a place where I can download PDO for php 4? I’ve found where to download the PDO extension but it requires PHP 5...
                    That’s just it, you don’t need PDO, because xPDO provides a subset PDO implementation for any version of PHP (after 4.3.3 at least) when PDO is not available automatically, or via a simple trick, it can even be used if PDO is available, but for some reason the correct PDO driver is not available.