-
☆ A M B ☆
- 24,524 Posts
Is 2261 totally unusable at this point? I got it installed with only two items not installed (a plugin and Jot tpl files not in the install folder) but there is something about a yearSkew not defined causing all kinds of hate and discontent when trying to log in to the Manager. The front-end seems OK.
-
☆ A M B ☆
- 24,524 Posts
The browser shows a long list of error messages, beginning with
Notice: Undefined variable: yearSkew in
/Applications/MAMP/htdocs/modx097alpha2267/core/xpdo/om/mysql/xpdoobject.class.php
on line 1533
then a whole bunch of issues with "headers already sent" due to that notice.
However, it does process the login, so going to the manager again works fine. It’s just that notice hanging things because of the headers for the notice being sent.
Ah, missed this... I get another one
Notice: Undefined variable: cookieLifetime in
... modx.class.php
on line 2011
Another notice about sessions already started on modx.class.php on line 2006... I guess my problem is my php is set to display notices.
-
☆ A M B ☆
- 24,524 Posts
I find the setDebug function, with its $stopOnNotice argument:
function setDebug($debug= true, $stopOnNotice= false) {
$oldValue= $this->getDebug();
if ($debug === true) {
error_reporting(E_ALL);
parent :: setDebug(true);
} elseif ($debug === false) {
error_reporting(0);
parent :: setDebug(false);
} else {
error_reporting(intval($debug));
parent :: setDebug(intval($debug));
}
$this->stopOnNotice= $stopOnNotice;
return $oldValue;
}
After completing a fresh install, clicked the ’close’ button to proceed to manager, and this error occured:
Warning: strtotime() [function.strtotime]: Called with an empty time parameter. in /Web_Server/modxdev/core/xpdo/om/mysql/xpdoobject.class.php on line 1532
...and a blank page. Had a couple other issues, which I reported in flyspray, but neither of those are critical.
Side Note:
After doing a little debugging, i found the exact time/line of the error occuring, in an odd place:
It happens when $modx->initialize(’web’) is run, and in modx.class.php on like 2008...the session_start(); command. Is there a reason that starting the session would cause a strtotime error? If I change the line to:
@session_start();, then the error doesn’t occur, and the manager loads fine.
Server info:
Mac OS X 10.4.8
MySQL 4.1.7-log
Apache/1.3.33 (Darwin)
PHP/5.0.5
mod_ssl/2.8.24
OpenSSL/0.9.7l
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com
-
MODX Staff
- 10,725 Posts
I found the problem in my xPDOObject::set() method when working with ’timestamp’ values mapped to numeric database values. I’m not treating the values properly and end up sending an ’empty’ time parameter to strtotime(). I’ll work on this later today and get it checked in. Just curious why that error shows up for you but not for me... :/
In any case, you can alternately just empty the configuration setting for session_handler_class and it will bypass the database-managed session handler which is triggering that error.