We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28042 ☆ A M B ☆
    • 24,524 Posts
    I had 1.2.1, and set it to PHP 4, and it was working that way. So I downloaded 1.4.1 ppc, saved my htdocs and db folders, and replaced the 1.2.1 with 1.4.1. I set it to the standard Apache and MySLQ ports and left it at PHP 5. Then I replaced the htdocs and db folders with my old ones. Everything worked immediately.
      Studying MODX in the desert - http://sottwell.com
      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
      Join the Slack Community - http://modx.org
      • 26435
      • 1,193 Posts
      ok, thanks.
      I will just try a fresh download of MAMP 1.4.1 when I get home.

      -sD-
        Husband, Father, Brother, Son, Programmer, Atheist, Nurse, Friend, Lover, Fighter.
        All of the above... in no specific order.


        I send pointless little messages
        • 10487 MODX Staff
        • 1,535 Posts
        Quote from: OpenGeek at Dec 21, 2006, 08:55 AM

        Quote from: Mark at Dec 21, 2006, 01:57 AM

        A clean install on PHP 5 (under MAMP) renders the following error on every page, manager or frontend
        
        Fatal error: Call to a member function bindValue() on a non-object in /Applications/MAMP/htdocs/modx_alpha/core/xpdo/xpdo.class.php on line 1482
        
        

        Which PHP 5 version is this?
        This is exactly the problem I’m having and is definitely related to my session problem, my version of PHP is 5.1.6. (I managed to finally find my error logs on my mac, lol)

        This error is also showing up but doesn’t seem to be causing any fatal issues so far:
        [Sat Dec 23 01:28:23 2006] [error] PHP Warning:  Memcache::get() [<a href='function.Memcache-get'>function.Memcache-get</a>]: cannot find connection identifier in /Library/WebServer/Documents/svn097/trunk/core/xpdo/cache/xpdocachemanager.class.php on line 124


        Hope that helps,
        Garry
          Garry Nutting
          Senior Developer
          MODX, LLC

          Email: [email protected]
          Twitter: @garryn
          Web: modx.com
          • 26435
          • 1,193 Posts
          I was getting the same error on my site5.com server until I followed your advice in the other thread. I am on php 5.2.0, but I do not have any errors logged other than the initial
          [21-Dec-2006 22:47:52] PHP Warning:  Unknown(): Unable to load dynamic library './php_pdo_mysql.so' - ./php_pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
          

          from before I commented out those lines.
          I also tried Jason’s recommended SQL code, and then emptied the cache file that susan mentioned. I eventually destroyed the db and the 097 folder and started from scratch. No joy, same errors, so for now I am leaving the session_set_save_handler stuff commented out.

          -sD-
          Dr. Scotty Delicious, Scientist.
            Husband, Father, Brother, Son, Programmer, Atheist, Nurse, Friend, Lover, Fighter.
            All of the above... in no specific order.


            I send pointless little messages
            • 26435
            • 1,193 Posts
            Well, It seems that thins are working ok, although probably without sessions.
            If you want to take a look and play around in the manager, please feel free to log in and play around.

            Please play around, edit, create, enjoy. Make a document, create a snippet.
            The only thing that I ask is that you be respectful. I am responsible for what happens to this shared server wink and also that if you log in, use the manager message center to send me (Scotty Delicious) a message letting me know you were there.

            The login credentials (All admin except for create/edit/delete users) for http://piratemachine.org/manager/:

            Username:modx
            Password:modx1234

            -sD-
            Dr. Scotty Delicious, Scientist.
              Husband, Father, Brother, Son, Programmer, Atheist, Nurse, Friend, Lover, Fighter.
              All of the above... in no specific order.


              I send pointless little messages
              • 22303 MODX Staff
              • 10,725 Posts
              Quote from: garryn at Dec 22, 2006, 07:35 PM

              This is exactly the problem I’m having and is definitely related to my session problem, my version of PHP is 5.1.6. (I managed to finally find my error logs on my mac, lol)

              This error is also showing up but doesn’t seem to be causing any fatal issues so far:
              [Sat Dec 23 01:28:23 2006] [error] PHP Warning:  Memcache::get() [<a href='function.Memcache-get'>function.Memcache-get</a>]: cannot find connection identifier in /Library/WebServer/Documents/svn097/trunk/core/xpdo/cache/xpdocachemanager.class.php on line 124


              Hope that helps,
              Garry
              The bindValue error means that native PDO is configured but the PDO MySQL driver is not initializing properly. You need to work this out with your MAMP install. Unfortunately, I can’t fix the fact that they do not know how to compile PHP properly with the things they are distributing.

              The warning is because apparently, you have the memcached extensions configured for PHP but your machine is not really running memcached? Is this running on a web cluster, or did someone just configure the memcached extension for no reason? I’m not sure why it would be throwing that error, especially if you did not enable the db_cache system setting. In any case, I guess I just need to make the preferred result-set cache provider configurable so it doesn’t even look for memcached extensions if they are configured but you don’t want to use them.
                • 22303 MODX Staff
                • 10,725 Posts
                Also, the session problem should simply be related to the missing system settings. If you add those and clear all your cache files and try again, that problem should go away, unless again, it is being caused by the bindValue() error, which means PDO MySQL is not configured properly even though PDO is.
                  • 10487 MODX Staff
                  • 1,535 Posts
                  Quote from: OpenGeek at Dec 23, 2006, 12:16 PM

                  The bindValue error means that native PDO is configured but the PDO MySQL driver is not initializing properly. You need to work this out with your MAMP install. Unfortunately, I can’t fix the fact that they do not know how to compile PHP properly with the things they are distributing.
                  Well, I’ve done some basic testing of PDO (found at: http://wiki.cc/php/PDO_Basics) and I can access the database fine outside of MODx. Looking at my phpinfo, both the PDO and PDO mySQL driver appear to be loaded as well. Is there anything else that could cause issues with PDO?

                  Quote from: OpenGeek at Dec 23, 2006, 12:18 PM

                  Also, the session problem should simply be related to the missing system settings. If you add those and clear all your cache files and try again, that problem should go away, unless again, it is being caused by the bindValue() error, which means PDO MySQL is not configured properly even though PDO is.
                  The system settings have been there since the beginning so this is definitely an issue with the bindValue() error.

                  The warning is because apparently, you have the memcached extensions configured for PHP but your machine is not really running memcached? Is this running on a web cluster, or did someone just configure the memcached extension for no reason?
                  Memcached is included in the Entropy distribution I’m using but I’m not using it ... so that’s okay. smiley As long as it doesn’t cause any serious downstream problems then I’m happy!
                    Garry Nutting
                    Senior Developer
                    MODX, LLC

                    Email: [email protected]
                    Twitter: @garryn
                    Web: modx.com
                    • 6726
                    • 7,075 Posts
                    A bit off topic but thanks for the pointer Garry, very interresting content about PDO grin
                    Got it bookmarked and will do my homework... many things I need to learn here !
                      .: COO - Commerce Guys - Community Driven Innovation :.


                      MODx est l&#39;outil id
                      • 22303 MODX Staff
                      • 10,725 Posts
                      EDIT: Garry and I figured out his problem was strictly related to the session handling. He removed the system setting session_handler_class completely, removed any /core/cache/ files and says it’s now working, though without the benefit of db managed sessions.

                      Quote from: garryn at Dec 23, 2006, 04:27 PM

                      Well, I’ve done some basic testing of PDO (found at: http://wiki.cc/php/PDO_Basics) and I can access the database fine outside of MODx. Looking at my phpinfo, both the PDO and PDO mySQL driver appear to be loaded as well. Is there anything else that could cause issues with PDO?
                      The problem is with the PDOStatement class, which depends on the driver specific to a db. Did you try one of the examples that creates a prepared statement? This is where the failure point is occuring. For some reason, the queries are not producing a PDOStatement object...and I’m at a loss.

                      Quote from: garryn at Dec 23, 2006, 04:27 PM

                      Memcached is included in the Entropy distribution I’m using but I’m not using it ... so that’s okay. smiley As long as it doesn’t cause any serious downstream problems then I’m happy!
                      I just need to change the way the db caching implementation is determined. Currently, if it sees that the memcached functions exist, it tries to automatically use it for caching database results. That’s actually a very good catch...