We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22303 MODX Staff
    • 10,725 Posts
    Ok this is RC2 (only I dropped the RC stuff cause I didn’t like it much; all future internal releases will be referenced by the SVN revision number of the project, in this case rev 538). Manager is reverted, more bugs fixed, more features, and changelog updated, but there are still some unresolved issues which we are still working on, including installation issues and latest snippets.

    @Core Snippet Authors -- If you could please help me get 0.9.1 ready by thoroughly testing your latest snippets (only those distributed with the core) and then you can send me all the updated files and I will commit it for you. If you are confident in your SVN skills, feel free to update them directly in the repository; just make sure they work before you do!
      • 24253
      • 125 Posts
      Getting an mysql-error here during install, see attached file

      This was an install with an existing database.
      The first install on this database was with modx-0.9, table prefix modx_
      Second addional install on this database was rev 538 with table prefix tattoo-rev538_

      A new clean database works out of the box, install wise ;-)

      Remon
        • 22303 MODX Staff
        • 10,725 Posts
        your table prefix is tattoo-rev538? try something without a dash for your prefix
          • 24253
          • 125 Posts
          ok, will try that, just a few seconds smiley
            • 24253
            • 125 Posts
            tattoo-rev538_
            


            as table prefix fails

            tattoorev538_
            


            as prefix works.

            Remon
              • 22303 MODX Staff
              • 10,725 Posts
              We should probably log that as a bug though and at least put some validation in on the db prefix value, depending on if this is a MySQL issue or an install code issue. Would you mind logging the bug in the tracker? I’d appreciate it.
                • 24253
                • 125 Posts
                How could I overlooked this easy to find one:

                Fatal error: Call to undefined function: str_ireplace() in /home/remon/public_html/tattoo-rev538/assets/modules/quick_edit/output.class.inc.php on line 269


                Ehm, thats what I see when I launch the site sad

                ofcourse, itworkswhennotlogged into the manager ;-)

                P.S.
                Will log it into the bug-tracker, sure I will smiley
                  • 22303 MODX Staff
                  • 10,725 Posts
                  Hmmm, yeah, looks like part of Adam’s commits that snuck in to this release under the wire today. Adam, can you take a look at this please?
                    • 18397
                    • 3,250 Posts
                    I will prepare a release version of NewsListing for 0.9.1 later today.

                    There are a few little things that should be cleaned up in v2.0 before its ready.

                    Jason, I’ll email it to you and post it on the site (for others to test) when its done as I don’t know SVN.
                      • 18397
                      • 3,250 Posts
                      As toQuote from: R.S. at Nov 28, 2005, 02:07 PM

                      Fatal error: Call to undefined function: str_ireplace() in /home/remon/public_html/tattoo-rev538/assets/modules/quick_edit/output.class.inc.php on line 269


                      Ummm, typo!


                      str_ireplace

                      should be

                      str_replace

                      :)