We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 25663 MODX Staff
    • 12,272 Posts
    http://vertexworks.com/forums/index.php?topic=527.0 -- some odd stuff going on it seems with SEF URLs

    http://vertexworks.com/forums/index.php?topic=524 -- new "copies" of FCK get added with every upgrade in teh RTE selector box (just duplicate entries)

    Also, the ability to create radio button or select lists no longer works for TVs.

    I’m sure there’s more but this seems like a couple of biggies to me... sounds like we’ll have a TP3.1 pretty quickly after all!
      Ryan Thrash, MODX Co-Founder
      Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
      • 25663 MODX Staff
      • 12,272 Posts
        Ryan Thrash, MODX Co-Founder
        Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
        • 22303 MODX Staff
        • 10,725 Posts
        I think a found another one...when redirecting me to the error page I’m getting a dialog from Firefox saying...

        Redirection limit for this URL exceeded. Unable to load the requested page. This may be caused by cookies that are blocked.

        You can see this problem at http://opengeek.com/home.html (I changed the alias to index.html and had a link leftover to home.html in WordPress that caused me to notice this issue).

        You get the same thing with any other page that does not exist.
          • 32963
          • 1,732 Posts
          Quote from: OpenGeek at Jul 18, 2005, 12:01 PM

          I think a found another one...when redirecting me to the error page I’m getting a dialog from Firefox saying...

          Redirection limit for this URL exceeded.? Unable to load the requested page.? This may be caused by cookies that are blocked.

          You can see this problem at http://opengeek.com/home.html (I changed the alias to index.html and had a link leftover to home.html in WordPress that caused me to notice this issue).

          You get the same thing with any other page that does not exist.


          Confirmed!

          This is what it actually looks like:

          http://opengeek.com/index.html&refurl=%2Findex.php%3Fq%3D404.shtml?err=1

          There’s a new feature inside the sendErrorPages that stores the initall url. I’ve used this feature to allow webLogins to be redirected to the secure page that the user had last requested after logging in.

          there’s something wrong with the order of the query strings in friendly url mode
            xWisdom
            www.xwisdomhtml.com
            The fear of the Lord is the beginning of wisdom:
            MODx Co-Founder - Create and do more with less.
            • 32963
            • 1,732 Posts

            These are now inside the Trunk:

            * fix friendly url bug when error page is being viewed
            * fix TV bug with drop-down menus (Jeff)
            * fix installer bug with duplicate plugin events
            * fix bug in site cache class with improper escape sequence

            What’s left to be done:

            * add <base href="$base_url"> to parser
            * set FCKConfig.AutoDetectLanguage = false - this might require a system setting to allow user to change when needed
              xWisdom
              www.xwisdomhtml.com
              The fear of the Lord is the beginning of wisdom:
              MODx Co-Founder - Create and do more with less.
              • 22303 MODX Staff
              • 10,725 Posts
              Quote from: xwisdom at Jul 19, 2005, 09:09 PM

              * fix friendly url bug when error page is being viewed

              Confirmed that this appears to be fixed...it is going to the correct page view now, and the URL looks like http://modxcms.com/home.html?refurl=%2Findex.php%3Fq%3Dindex.html&err=1 - so I think it’s correct... wink
                • 32963
                • 1,732 Posts

                new fixes

                * fix bug with user screens and postbacks
                * fix bug in DBAPI select()
                * add FCKConfig AutoDetectLanguage system settings
                * add <base href="$base_url"> to parser for friendly url paths

                I guess that should do it for TP3.1?

                Jason, can you confirm the <base> stuff?
                  xWisdom
                  www.xwisdomhtml.com
                  The fear of the Lord is the beginning of wisdom:
                  MODx Co-Founder - Create and do more with less.
                  • 22303 MODX Staff
                  • 10,725 Posts
                  Quote from: xwisdom at Jul 21, 2005, 11:51 AM

                  new fixes

                  * fix bug with user screens and postbacks
                  * fix bug in DBAPI select()
                  * add FCKConfig AutoDetectLanguage system settings
                  * add <base href="$base_url"> to parser for friendly url paths

                  I guess that should do it for TP3.1?

                  Jason, can you confirm the <base> stuff?

                  Base stuff works like a charm...but I got this when running upgrade:

                  MODx setup couldn’t install/alter some tables inside the selected database.

                  The following errors had occured during installation

                  Unknown column ’content_dispo’ in ’modx_site_content’ during the execution of SQL statement ALTER TABLE `modx_site_content` ADD COLUMN `hidemenu` TINYINT(1) NOT NULL DEFAULT 0 COMMENT ’Hide document from menu’ AFTER `content_dispo`.

                  My content tree disappeared in the manager following this upgrade...
                    • 32963
                    • 1,732 Posts
                    Hmmm,

                    I think you where upgrading from one of my previous SVN Branch uploads smiley If that’s the case you would to manually update the database.

                    Anyway here’s the fix for that:

                    ALTER TABLE `{PREFIX}site_content` ADD COLUMN `menutitle` VARCHAR(30) NOT NULL COMMENT ’Menu title’ AFTER `deletedby`
                    , ADD COLUMN `donthit` TINYINT(1) NOT NULL default ’0’ COMMENT ’Disable page hit count’ AFTER `menutitle`
                    , ADD COLUMN `haskeywords` TINYINT(1) NOT NULL default ’0’ COMMENT ’has links to keywords’ AFTER `donthit`
                    , ADD COLUMN `hasmetatags` TINYINT(1) NOT NULL default ’0’ COMMENT ’has links to meta tags’ AFTER `haskeywords`
                    , ADD COLUMN `privateweb` TINYINT(1) NOT NULL default ’0’ COMMENT ’Private web document’ AFTER `hasmetatags`
                    , ADD COLUMN `privatemgr` TINYINT(1) NOT NULL default ’0’ COMMENT ’Private manager document’ AFTER `privateweb`;


                    ALTER TABLE `{PREFIX}site_content` ADD COLUMN `content_dispo` TINYINT(1) NOT NULL default ’0’ COMMENT ’0-inline, 1-attachment’ AFTER `privatemgr`;

                    The new setup.sql should also be inside the trunk
                      xWisdom
                      www.xwisdomhtml.com
                      The fear of the Lord is the beginning of wisdom:
                      MODx Co-Founder - Create and do more with less.
                      • 22303 MODX Staff
                      • 10,725 Posts
                      Quote from: xwisdom at Jul 21, 2005, 10:21 PM

                      I think you where upgrading from one of my previous SVN Branch uploads smiley If that’s the case you would to manually update the database.

                      Actually, this was the latest post TP3 updates in SVN, but fair enough, it wasn’t an actual release. Thanks for the fix regardless.

                      This discussion is closed to further replies. Keep calm and carry on.