-
☆ A M B ☆
- 117 Posts
Hi,
I am trying to use Maltese in ModX Manager, using the special characters ħ, ż, ġ and ċ in the Resources (pagetitle, longtitle,content areas etc). The problem is that when I save ModX replaces these characters with the question mark character (?).
So if I write something like this in the pagetitle input box: "Għaliex", as soon as I save it becomes "G?aliex"
I guess it’s the character encoding or something of the sort :/. Anyone got a solution?
Thanks in Advance and keep up the good work!
That probably means a mismatch between the character set/collation in the DB, DB Tables, DB fields, and/or the Manager character set.
Usually it’s a conflict between Latin1 and UTF-8.
If you need to alter it, see this:
http://bobsguides.com/convert-db-utf8.html
-
☆ A M B ☆
- 117 Posts
Are you aware of a method where I don’t have to tweak the database, because I’m afraid I don’t have full control over the database?
Quote from: sjmclean at Jan 24, 2011, 04:37 PM
Are you aware of a method where I don’t have to tweak the database, because I’m afraid I don’t have full control over the database?
I’m not an expert on character sets (I’m not sure anyone is).
See if there is a line at the top of your template specifiying the character set. Sometimes changing that to match the the DB is enough.
You might be able to use Set Names or Set Character Set in the main index.php file or the config.inc.php file. I’ve never done it because my DBs are all UTF-8.
There’s more information here (good luck making any sense out of it):
http://dev.mysql.com/doc/refman/5.0/en/charset-connection.html
-
☆ A M B ☆
- 117 Posts
Yeps, I think that checking the config.inc.php is the best option.
The problem is that Modx versions 1.0.3 and below is allowing me to download their config.inc.php and the one I need to download which runs on Modx version 1.0.4 is not allowing me to :/. (Not only for this website, but all websites running on 1.0.4 is presenting the same problem)
I’m not sure what could be causing that, but you should be able to get to it with the cPanel File Manager.
When you say "not letting me," what do you mean? How are you trying to get it and what’s happening?
-
☆ A M B ☆
- 117 Posts
When I try to download it using the FTP, I get the following error message:
Response: 550 config.inc.php: Operation not permitted
Error: Critical file transfer error
Then I have tried to set permissions to 777 (from 600), but when trying to change the permission it doesn’t let me either and gives me the following error:
Status: Set permissions of ’/httpdocs/manager/includes/config.inc.php’ to ’777’
Command: SITE CHMOD 777 config.inc.php
Response: 550 CHMOD 777 config.inc.php: Operation not permitted
From the CPanel it gives similar errors.
Quote from: sjmclean at Jan 25, 2011, 01:10 AM
When I try to download it using the FTP, I get the following error message:
Response: 550 config.inc.php: Operation not permitted
Error: Critical file transfer error
Then I have tried to set permissions to 777 (from 600), but when trying to change the permission it doesn’t let me either and gives me the following error:
Status: Set permissions of ’/httpdocs/manager/includes/config.inc.php’ to ’777’
Command: SITE CHMOD 777 config.inc.php
Response: 550 CHMOD 777 config.inc.php: Operation not permitted
From the CPanel it gives similar errors.
See if it will let you set the permissions to 755 for folders and 644 for files.
-
☆ A M B ☆
- 117 Posts
It is set so from ModX yes, exactly as described.
I dunno why such a problem doesn’t effect ModX versions 1.0.3 and below :S