Thanks for the replies
After trial and error we discovered the problem lies in Wayfinder’s flyout cssplay menu. In the instance of creating a sub-category(level 2, snippet has a &level=3) in any of the main categories IE7 stops outputting wherever that sub-category should be. We are now in the process of working the css a little to see if therein lies the problem, but at least we found the cause
krypto
<edit> Well... I deleted everything related to wayfinder, uploaded and unzipped wayfinder on the server and rewrote all the chunks etc... and lo and behold everything works fine now.
As for fixing my markup, it seems to me that 99.9% of everything kicked out by the validator is related to FURLs. I am no htaccess wizard, I just know I cannot get it to work on these virtual URLs but once we make the switch to it’s domain then they (FURLs) work fine. Thanks for the input

</edit>