We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14246
    • 3 Posts
    I recently took over a website that continues to spit out the following errors until the server returns an Internal Server Error 500. I am not familiar at all with ModX, so I’m hoping someone in this forum can help me resolve the issue. I was able to login to the backend of ModX and find the Plugins section, but have no idea how to remedy this error message. What I do know, however, is that the highslide.js folder does NOT exist and that’s all that needs to be done to fix the path of this error.

    Please forgive what is, I’m sure, the absolute most basic of questions on this board, but I really need some help because the website won’t even open in a browser window due to these errors.

    Any help out there would be greatly appreciated!

    Thank you!

    [Tue Feb 8 09:40:26 2011] [error] [client 75.158.197.180] File does not exist: /var/chroot/home/content/s/i/m/simplesoft1/html/assets/plugins/directresize/libs/highslide/highslide.js/graphics/loader.white.gif
    [Tue Feb 8 09:42:05 2011] [error] [client 174.56.141.46] File does not exist: /var/chroot/home/content/s/i/m/simplesoft1/html/assets/plugins/directresize/libs/highslide/highslide.js/graphics/loader.white.gif
    [Tue Feb 8 09:48:18 2011] [error] [client 201.114.56.108] File does not exist: /var/chroot/home/content/s/i/m/simplesoft1/html/assets/plugins/directresize/libs/highslide/highslide.js/graphics/loader.white.gif
    [Tue Feb 8 09:48:27 2011] [error] [client 201.114.56.108] File does not exist: /var/chroot/home/content/s/i/m/simplesoft1/html/assets/plugins/directresize/libs/highslide/highslide.js/graphics/loader.white.gif
      • 1343 ☆ A M B ☆
      • 2,213 Posts
      Hello,

      Look for a Direct Resize plugin and disable it. Then under home > clear site cache. The site should be accessible until you are able to fix the problem at hand. In regards to the actual problem it looks like the site creator is trying to use the server to resize images, but the implementation is a little off.

        Patrick | Server Wrangler
        About Me: Website | Tweets |  MODX Hosting
        • 14246
        • 3 Posts
        AMDBuilder, thank you so much for the response! Prior to posting this message, I was able to find the DirectResize Plugin (although there’s a typo and it’s called DirecrResize) but I figured it was trying to be used somewhere on the site. I’ll disable, but I’m sure it’s needed somewhere. I just don’t know where though. Then I’ll clear my browser’s cache to see if that stops the error messages.

        I’m afraid I may have to re-enable the Plugin if it adversely affects the website in general. Guess I’ll cross that bridge when I come to it.

        I appreciate the response greatly!
          • 1343 ☆ A M B ☆
          • 2,213 Posts
          Hello JK15060,

          You need to clear the site’s cache, not your browser cache. Disabling the plugin will cause any dynamically resized images to revert to their full size, but the site will be accessible until you can clear up the issues.

          I suspect you may need to use Direct Resize directly instead of in plugin form as currently configured. If I recall correctly the plugin method is known to cause issues (at least in my experience)
            Patrick | Server Wrangler
            About Me: Website | Tweets |  MODX Hosting
            • 14246
            • 3 Posts
            Again, I can’t thank you enough for your help AMDBuilder! I’m glad I checked this forum one last time before starting on something else. Never even thought about the ModX cache being cleared, but focused more on the browser. Big ole DUH on my part. Found the ModX cache under Site | Clear Cache.

            And, as expected, the errors stopped completely the minute that pesky plugin was disabled. Whew! I still don’t know the ramifications of disabling that plugin, but just stopping all those errors is enough to warrant a drink. smiley

            Thanks again!