On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I found this great free software: Usb Webserver 6 which let you run a complete webserver (Apache 2.2.0 (Win32), PHP 5.1.6, MySQL 5.0 and phpMyAdmin 2.9.0-rc1) on a usb stick (site language can be set to english).

    I thought this would be very usefull developing/demonstrating sites with MODx and also when developing snippets. So I tried to install MODx 0.9.5 on my usb stick.

    First problem: file access on my usb stick was too slow so I got a timeout error. I copied all files to my harddisk and tried again which was successfull. After that I copied all files back to my usb stick and changed the paths accordingly.

    After some tests I found that plugins like QuickEdit and snippets like Wayfinder don’t work >:(

    This is the error I keep getting:
    « MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource: 
    « PHP Parse Error » 
      
    PHP error debug 
      Error:  include_once(assets/modules/quick_edit/output.class.inc.php) [function.include-once]: failed to open stream: No such file or directory   
      Error type/ Nr.:  Warning - 2   
      File:  E:\UsbWebserver\Root\manager\includes\document.parser.class.inc.php(724) : eval()'d code   
      Line:  70   
      
    Parser timing 
      MySQL:  0.0274 s (4 Requests) 
      PHP:  0.1077 s   
      Total:  0.1351 s 
    


    I was thinking the paths weren’t set correctly, so I tried all kinds of entries but still no luck.

    I still think this software in combination with MODx could be very helpfull.

    So I my question is if there are any experts out there who can get MODx work properly with this software? huh


        • "He can have a lollipop any time he wants to. That's what it means to be a programmer."
        • Thank you guys for putting some interesting links up here. Portable xampplite seems to work perfectly smiley

          Still, UsbWebserver is about 100Mb smaller, and has an easy to use interface. When configured, you just have to start Usbwebserver.exe and it not only starts Apache and MySQL, but also the browser with the homepage of the site smiley

          Would love to find out why Modx isn’t working properly on this one... rolleyes