On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I'm using Rev2.2.0 + IIS7 with the URL Rewrite Module Go Live release installed and it seems to be working fine. You have to import the .htaccess file which URL Rewrite converts to xml, and don't be surprised if you have to install URL Rewrite, un-install it and re-install it again inorder to get it to show up in the management panel, seems to be a common issue.


    http://www.iis.net/download/URLRewrite
    • Hey Patrickc - thanks!!!

      With the help of my tech buddy, and your advice, we did the following to make Search Engine Friendly URL's work in IIS (free). I don't know IIS but these are the steps I remember my mate taking:

      1. Install URL Rewrite Module onto server (we have remote access and control over a virtual private server)

      2. Once installed, follow these instructions: http://www.iis.net/learn/extensions/url-rewrite-module/importing-apache-modrewrite-rules - I seem to remember my mate skipping straight to the 'Convert mod_rewrite Rules' instructions - but don't quote me on that!

      3. Import the MODX .htaccess file. The MODX .htaccess file has most of the stuff commented out by default. We left it that way as we were only concerned with the 'friendly url' part of it, which is not commented out by default.

      4. Note: URL Rewrite didn't successfully import the 'URL base' segment, (whatever that is) but we simply commented it out on the actual user interface of URL Rewrite and finished the import

      > Then in MODX site settings, we enabled 'friendly URL's' and 'strict friendly URL's'

      > Finaly in each MODX resource that you have, fill in the 'resource alias' field with whatever u want the URL to look like.

      Seems to work so far, and forms are processing OK

      Kind regards

      Asaf