We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 6369
    • 18 Posts
    I get this errror everytime I try to access my domain.

    Warning: include_once(/home/wemyssw1/core/model/modx/modx.class.php) [function.include-once]: failed to open stream: No such file or directory in /home/wemyssw1/public_html/index.php on line 28

    Warning: include_once() [function.include]: Failed opening ’/home/wemyssw1/core/model/modx/modx.class.php’ for inclusion (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/wemyssw1/public_html/index.php on line 28


    modx revolution 2.0.6 pl2 traditional
    linux server
    Apache version 2.2.16
    PHP version 5.2.14
    MySQL version 5.0.91-community
    firefox 3.6.13
      • 22835
      • 54 Posts
      (this may not be exactly your issue but is caused me some hassle)

      If you’ve already installed and are trying to reinstall again you wont find the setup folder as it’s automatically deleted after an install. You have to ftp up the setup folder again.
        • 3749
        • 24,544 Posts
        It’s not the setup dir. that’s missing. It’s failing to find the modx class file.

        First, find that file (modx.class.php). It should be where the error message says it’s looking for it.

        Is this a fresh install or an upgrade?
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 6369
          • 18 Posts
          I have a different problem. When I navigate to my domain wemyssweb.net I get this?

          Index of /

          * 404.shtml
          * Dale/
          * _vti_bin/
          * _vti_inf.html
          * cgi-bin/
          * images/
          * modx-2.0.7-pl/
          * postinfo.html

          When I click on * modx-2.0.7-pl/ I get this response

          503 Error

          Site temporarily unavailable.

          The modx file is in the public_html directory and the www directory.
          Traditional revolution install
          cPanel Version 11.28.64
          Apache version 2.2.16
          PHP version 5.2.14
          MySQL version 5.0.91-community
          Architecture x86_64
          Operating system linux
            • 3749
            • 24,544 Posts
            It looks like for some reason, the "web root" of your domain is not set to public_html so the server is not looking there.

            It might be best to just file a ticket with the hosting service. They can probably fix it very easily for you.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 6369
              • 18 Posts
              My web root is set to public_html.When I submitted a support ticket to justhost.com I got this response.

              For your site to be displaying on-line please make sure that all your files are uploaded directly to ’public_html’, without any sub-folders.
              If there are still any issues please let me know and I’ll assist you further.

              So I moved all the files out of the modx directory to public_html directory and got this response.

              503 Error

              Site temporarily unavailable.

              Would this part of index.php cause this?


              }
              /* include the modX class */
              if (!@include_once (MODX_CORE_PATH . "model/modx/modx.class.php")) {
                  $errorMessage = 'Site temporarily unavailable';
                  @include(MODX_CORE_PATH . 'error/unavailable.include.php');
                  header('HTTP/1.1 503 Service Unavailable');
                  echo "<html><title>Error 503: Site temporarily unavailable</title><body><h1>Error 503</h1><p>{$errorMessage}</p></body></html>";
                  exit();


                • 3749
                • 24,544 Posts
                Yes it would if it can’t find the MODx class file in that location.

                Do you have an .htaccess file? If so, try renaming it to ht.access so it will be ignored.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 6369
                  • 18 Posts
                  I have ht.access, htaccess, htaccess123 huh
                    • 28042 ☆ A M B ☆
                    • 24,524 Posts
                    The only one that counts is .htaccess (notice that it begins with a . )
                      Studying MODX in the desert - http://sottwell.com
                      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                      Join the Slack Community - http://modx.org
                      • 6369
                      • 18 Posts
                      The .htaccess file was empty and the .htaccess123 is for windows extentions.
                      The ht.access file is a modx configuration file huh