We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22860
    • 1 Posts
    Hey guys. I’m installing MODx and I just ran into a problem.

    I’m on the Pre-install validation part of the installation.

    The following check came back with a failure:
    "Checking if /manager/includes/config.inc.php exists and is writable: FAILED!

    For new Linux/Unix installs, please create a blank file named config.inc.php in the /manager/includes/ directory with file permissions set to 0666."

    Everything else checked out.

    I’m on windows hosting with GoDaddy. I’m using the following tutorial: http://codingpad.maryspad.com/2009/03/29/building-a-website-with-modx-for-newbies-part-2-installing-modx/ to help with the installation.

    Please help me! Thanks guys.
      • 16895
      • 87 Posts
      Create a blank text file on your local computer with something like notepad, notepad++, gedit etc. (not with Word, Writer or any other word processor).

      Save it with the file name ’config.inc.php’, making sure that it does not end up as a text file like ’config.inc.php.txt’---it must be a php file.

      Use an FTP program like FileZilla to access your site via FTP (if you’re not doing this already you can get the settings from your host). Navigate to the /manager/includes/ directory of your site on the right hand side, and to the blank text file on the left hand side, then drag the file from the left to the right pane. Now wait for it to upload, then right click on it and select ’File Permissions...’. Set the ’Numeric value:’ field to 666 and click OK.

      The problem should be solved.