I cannot get past the point of installation where the connections are tested. My server connection passed, but I cannot get the database connect to pass. I’ve tried two different servers and get the same message for both: "Checking database: failed - could not create database"
Database name: modx
Table prefix: plusclu1_
Connection method: SET CHARACTER SET
Collation: utf8_general_ci
I’ve changed the permissions to 0777 as the installation guide suggests. I don’t know what else to do. I am not an expert at these things, but it seems like there are way too many hoops to jump through just to install this program. It shouldn’t be this hard! I’ve already spent 3 hours trying to make this thing work and am ready to throw in the towel. If you can offer any suggestions, I would be much appreciative.
have you tried manually creating the database?
-
☆ A M B ☆
- 24,524 Posts
I rather imagine that the database that is created in your CPanel has a prefix of some kind prepended to the database name you specify. Usually this is a certain number of characters from your domain name, or your CPanel login name. So if you create a database named "mydata", then try to connect to it, the connection attempt will fail, because your database is really named "mydom_mydata".
Thanks for the suggestion, sottwell, but when I added the prefix to the database name at the install prompt, it still failed. This is what I have tried:
Database name: modx
Table prefix: plusclu1_
Connection method: SET CHARACTER SET
Collation: utf8_general_ci
Database name: plusclu1_modx
Table prefix: plusclu1_
Connection method: SET CHARACTER SET
Collation: utf8_general_ci
I’ve not worked with a database before and I’m not sure how to even access it from my cpanel to be sure its working.
I am attempting to install evolution 1.0.2. Wondering if I should just remove it all from my server and try installing the previous version?
-
☆ A M B ☆
- 24,524 Posts
Depends on what you want to do with it. There are quite a few sites with beginner tutorials and articles; mine is here
http://www.sottwell.com/modx-from-the-inside.html
Actually, your problem wasn’t with installing MODx, it was with using CPanel. Website design and development often branches out into server and database administration and a multitude of other support technologies. I had a head-start on this, since I ran an old-style BBS system (Maximus for DOS and for OS/2 and Excalibur for Windows 3.11) before the Internet became popular, and ran my own OS/2, Linux and Novell servers for years before I began working with web design.
It sounds like on your first try, you created the database, but just forgot to create a user that could access it.
From the link you posted:
7. Create a new database user account for MODx to use and associate it with the database you just created.
Note: you must set sufficient rights for the user for that database (eg. create table, select, insert, update, delete , etc. Safe bet is to put all rights). Don’t forget to write down the user name and password you create!
I’ve just edited the Wiki in an attempt to make it clearer.
FYI: You didn’t need to change the table prefix from modx_ (though doing so won’t hurt anything). That option is just there in case you have more than one MODx install using the same database.
-
☆ A M B ☆
- 2,475 Posts
Yep, as Bob pointed out, you have to associate users with databases... that’s just a MySQL permissions thing; it’s not peculiar to MODx.