We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 18748
    • 5 Posts
    Hi, newbie to MODx

    Uploaded the large (8Mb+) install zip and unpacked it, eventually got the subfolder under public_html
    [which is I assume where they go - documentation does not state where.]

    navigated to setup folder (as doco states) - I got 3 warnings (the cache folder permissions I fixed)

    now I’m left with these 2 under the fatal error banner:

    FATAL ERROR: MODx Setup cannot continue.

    * MODx requires the PDO extension when native PDO is being used and it does not appear to be loaded.
    * MODx requires the pdo_mysql driver when native PDO is being used and it does not appear to be loaded.

    So, off to Cpanel (yep this is all I have access to) and try to install PDO (whatever that is)
    I assume this is a PHP module, so eventually locate it as such and ask for it to install
    I then get the following:

    Failed to download pear/Structures_DataGrid within preferred state "stable", latest release is version 0.9.0, stability "beta", use "channel://pear.php.net/Structures_DataGrid-0.9.0" to install
    pear/Structures_DataGrid_DataSource_PDO requires package "pear/Structures_DataGrid" (version >= 0.8.4)
    No valid packages found
    install failed
    /usr/local/jdk/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib/courier-imap/sbin:/usr/lib/courier-imap/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/X11R6/bin:/root/bin:/opt/bin

    Any clues on how I get past this point? It’s a LAMP site but only with Cpanel style access.

    I’ll try the site admins - but think they will push me off due to the "beta" reference to this PHP package.

    Thanks.


      • 28042 ☆ A M B ☆
      • 24,524 Posts
      If you are using PHP 5 getting your tech support to install the proper PDO drivers for MySQL should not be a problem; but then these should be enabled to begin with. PHP 4 is another matter; it does not include PDO. However, MODx has the ability to use PHP 4 libraries for xPDO. Try posting in the 2.0 Revolution forums for better responses.

      http://modxcms.com/forums/index.php/board,378.0.html
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 18748
        • 5 Posts
        Solved! (well this specific issue is, there’s more for me to do)

        Site Admins added the necessary,
        have got through the install (not happy about public_html needing write!) and
        trying to figure out why I get a ’page not found’ at the public site.

        more hunting/pecking to do
        I also discovered that IE 6 is completely useless in the /manager area (not that surprised) but I could not even logout - which is sort of disturbing.

        Will find the suggested board - I’m surprised their isn’t a board specifically for Installations - ah well new community new ways of thinking.

        Cheers.
          • 28215
          • 4,149 Posts
          Quote from: maxad at Oct 07, 2009, 03:34 PM

          have got through the install (not happy about public_html needing write!) and
          This will be fixed in the upcoming beta releases.


          trying to figure out why I get a ’page not found’ at the public site.
          In Revolution, until we get out of beta, there is no demo content. You’ll need to create a Template and site_start Resource for the site to work.


          I also discovered that IE 6 is completely useless in the /manager area (not that surprised) but I could not even logout - which is sort of disturbing.
          Revolution’s manager will not support IE6.
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com