We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 17261
    • 18 Posts
    I have had modX running successfully for over two weeks, and having completed all that I needed a few days back, I have not touched the site (but have had no issues viewing the site). Last night, I tried modifying it again but ran into this error:

    "Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request."

    I get the same error when I try to go to the manager. What happened?

    If anyone wants to see the error, here’s a link: http://yuriofjapan.com/

    The site is on a Linux server running Apache 2.2.11 and PHP 5.2.9.
      • 9207 ☆ A M B ☆
      • 2,475 Posts
      Looks like it’s working now. Internal Server Errors can be caused by a lot of different things... heavy traffic, permissions errors, bad .htaccess files....

      What did you change? My advice with programming PHP is this: test your pages OFTEN... literally after every couple changes. That way you can always keep tabs on what caused something to break.

      Hope everything is working for you now!
        • 17261
        • 18 Posts
        I contacted technical support for the server and they just fixed it. I have no idea what they did, but I’m positive they caused the error - seeing as I didn’t modify the site at all to cause it to give me this error. Thanks for the look though, Everett!