We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28019
    • 4 Posts
    Checking if assets/cache/siteCache.idx.php file is writable: FAILED!

    Checking if assets/cache/sitePublishing.idx.php file is writable: FAILED!

    I’ve changed the permissions on these files to 666, and even gone as far as to change them to 777, but the install script doesn’t see them as writable still for some reason. The directory they’re in has been made writable as well. All other checks pass.

    What’s the deal?

    Thanks in advance,

    -Sootah
      • 28019
      • 4 Posts
      Also, MODx version 0.9.6.3 is in use.
        • 4310
        • 2,310 Posts
        AFAIK both folders assets/ , cache/ and the siteCache.idx.php & sitePublishing.idx.php files have to be 777 or on some servers 755.
        Are the changed permissions sticking, again I’ve had a couple of times where my permissions won’t stick on IIS servers and it needed the host to do it.
          • 28019
          • 4 Posts
          You were correct. When I set the /cache folder as well as the files to 777 I was able to finish the install.

          Thanks!
            • 28019
            • 4 Posts
            How do I mark this thread as solved, or do I simply edit the thread title and insert [Solved] in the beginning?
              • 3749
              • 24,544 Posts
              Quote from: Sootah at Apr 29, 2009, 04:16 PM

              How do I mark this thread as solved -- do I simply edit the thread title and insert [Solved] in the beginning?

              Yes, and thanks in advance for doing that. smiley
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting