We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 19946
    • 15 Posts
    After the installation I found the name and position of the path not pleasant so i changed it.
    It was: httpdocs/modx-0.9.6.3/modx-0.9.6.3
    and i changed it into: httpdocs/cms

    In the modx manager ’ve changed in configuration the following:
    Resource path, resource url and file manager path
    Also the pre-installed eform snippet needed manual adjustments.

    At the moment my doc manager and quickedit module arent working anymore. I think other pre installed snippets (which im not using) could also have problems.

    Main question: How can i change the path throughout modx and leave those annoying wrong reference paths behind me?

    (found something but not completely satisfying: http://modxcms.com/forums/index.php/topic,34524.msg209852.html#msg209852)
      • 26931
      • 2,314 Posts
      hi,

      did you clear the MODx-cache?

      j
        • 19946
        • 15 Posts
        Quote from: sharkbait at Apr 25, 2009, 06:47 AM

        hi,

        did you clear the MODx-cache?

        j

        yes, in the manager ’site-clear cache’. But didn’t work. It also seems a permission problem. In the manager; ’site-preview’ responds with a " 403 Forbidden
        You do not have permission to access this document. "

        And ’resources-manage files’ gives a "Directory listing for:/    Access denied!"
          • 26931
          • 2,314 Posts
          hmmm...then maybe check the permissions?

          If you are installing on to a Linux/Unix computer, you need to CHMOD the following files/folder so that your Apache user has write access to them (can be easily done with a good FTP client). If you don’t know what CHMOD rights you should set, try 0666 (rw-rw-rw-). If you get a screen in the installation that tells you that some directories are not writeable by the server, change the CHMOD settings to 0777 (rwxrwxrwx) for the following directories:

          * /assets/cache folder and all files inside it, except index.html
          * /assets/export folder
          * /assets/images folder
          * /manager/includes/config.inc.php NOTE! The write access must be removed from this file after successful installation. Write down the current read-only CHMOD setting for later use. (usually 0644)
            • 19946
            • 15 Posts
            I still think it’s caused by a wrong reference path. Because the link to the preview site path says ’website’/cms, it should be ’website’.

            Furthermore, in the quickedit snippet there is: $modx->config[’base_path’].’assets/modules/quick_edit’; }
            Probably it retrieves the wrong base_path. Where does the snippet gets the base_path from? Does anyone know where i can change this base_path?
              • 19946
              • 15 Posts
              Quote from: sharkbait at Apr 25, 2009, 07:05 AM

              hmmm...then maybe check the permissions?

              If you are installing on to a Linux/Unix computer, you need to CHMOD the following files/folder so that your Apache user has write access to them (can be easily done with a good FTP client). If you don’t know what CHMOD rights you should set, try 0666 (rw-rw-rw-). If you get a screen in the installation that tells you that some directories are not writeable by the server, change the CHMOD settings to 0777 (rwxrwxrwx) for the following directories:

              * /assets/cache folder and all files inside it, except index.html
              * /assets/export folder
              * /assets/images folder
              * /manager/includes/config.inc.php NOTE! The write access must be removed from this file after successful installation. Write down the current read-only CHMOD setting for later use. (usually 0644)

              These permission changes didn’t work.
                • 19946
                • 15 Posts
                in the manager "reports-system events" also says:
                "QuickEdit module not found!
                Edit the QuickEdit module, click the Configuration tab and change the Module Path to point to the module."

                But when i edit the path it gives an error because of double paths statements:

                PHP error debug
                Error: Output::include_once(/var/www/vhosts/’website’/httpdocs/cms/cms/assets/modules/quick_edit/lang/english.inc.php) [output.include-once]: failed to open stream: No such file or directory
                Error type/ Nr.: Warning - 2
                File: /var/www/vhosts/’website’/httpdocs/cms/assets/modules/quick_edit/output.class.inc.php
                Line: 55
                Line 55 source: include_once ($qe_eng_path);

                Somehow quickedit needs the path "cms/assets/modules/quick_edit" to be initialized.
                But because output.include-once.php gets also the modx basepath, at some line, it doubles the cms part.
                  • 26931
                  • 2,314 Posts
                  that’s odd  huh

                  have you got this part in the header of your template:
                  <base href="[(site_url)]"></base>


                  and...if you are using friendly URLs , you have to change the RewriteBase in your .htaccess file as well
                    • 19946
                    • 15 Posts
                    i don’t have that line in my header, what’s it for? When i put it in the header i don’t see any change. (still clearing cache)

                    I’m using User friendly url’s. When i put ’Rewritebase /cms’ (my modx folder) in .htaccess i only can visit www.mywebsite.bla but not any other site like www.mywebsite.bla/page.html. With the latter i receive  500 internal server error.

                    No luck on quickedit and manage files.

                    when i started using the htaccess file of modx i edited it for user friendly urls, and i replaced the existing htaccess file. Could that be the problem? i have a backup of that file.

                    The old file says:
                    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

                    <Limit GET POST>
                    order deny,allow
                    deny from all
                    allow from all
                    </Limit>
                    <Limit PUT DELETE>
                    order deny,allow
                    deny from all
                    </Limit>
                    AuthName mywebsite.bla
                    AuthUserFile /var/www/vhosts/mywebsite.bla/httpdocs/_vti_pvt/service.pwd
                    AuthGroupFile /var/www/vhosts/mywebsite.bla/httpdocs/_vti_pvt/service.grp

                      • 19946
                      • 15 Posts
                      Maybe important to mention, before i changed the foldername and moved the directory, the file manager and quickedit did function properly.