hi,
did you clear the MODx-cache?
j
I still think it’s caused by a wrong reference path. Because the link to the preview site path says ’website’/cms, it should be ’website’.
Furthermore, in the quickedit snippet there is: $modx->config[’base_path’].’assets/modules/quick_edit’; }
Probably it retrieves the wrong base_path. Where does the snippet gets the base_path from? Does anyone know where i can change this base_path?
in the manager "reports-system events" also says:
"QuickEdit module not found!
Edit the QuickEdit module, click the Configuration tab and change the Module Path to point to the module."
But when i edit the path it gives an error because of double paths statements:
PHP error debug
Error: Output::include_once(/var/www/vhosts/’website’/httpdocs/cms/cms/assets/modules/quick_edit/lang/english.inc.php) [output.include-once]: failed to open stream: No such file or directory
Error type/ Nr.: Warning - 2
File: /var/www/vhosts/’website’/httpdocs/cms/assets/modules/quick_edit/output.class.inc.php
Line: 55
Line 55 source: include_once ($qe_eng_path);
Somehow quickedit needs the path "cms/assets/modules/quick_edit" to be initialized.
But because output.include-once.php gets also the modx basepath, at some line, it doubles the cms part.
i don’t have that line in my header, what’s it for? When i put it in the header i don’t see any change. (still clearing cache)
I’m using User friendly url’s. When i put ’Rewritebase /cms’ (my modx folder) in .htaccess i only can visit www.mywebsite.bla but not any other site like www.mywebsite.bla/page.html. With the latter i receive 500 internal server error.
No luck on quickedit and manage files.
when i started using the htaccess file of modx i edited it for user friendly urls, and i replaced the existing htaccess file. Could that be the problem? i have a backup of that file.
The old file says:
IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
<Limit GET POST>
order deny,allow
deny from all
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthName mywebsite.bla
AuthUserFile /var/www/vhosts/mywebsite.bla/httpdocs/_vti_pvt/service.pwd
AuthGroupFile /var/www/vhosts/mywebsite.bla/httpdocs/_vti_pvt/service.grp
Maybe important to mention, before i changed the foldername and moved the directory, the file manager and quickedit did function properly.