Hi
I am a newcomer to modx and love it apart from some odd installation issues.
I tested modx on my local pc using xampp and everything worked ok including AjaxSearch, Logins, Contact Forms etc.
I have since installed modx on 2 sites. Both are hosted by hosts Dziner on what I think are identical though fairly cheap hosting packages.
My first installation appeared to install ok and templates, tv’s, chunks and snippets all loaded ok and the basic site is fine with basic pages loading ok but there are a number of problems.
AjaxSearch returns no results and just keeps spinning. The login refuses to show on the default test site page or the Login Page and instead shows the email address field as if I have already attempted to login. No amount of refreshing resolves this. Trying to visit the login page fails to load the login page or user name and password fields and goes straight to the page suggesting signup has been successful. Also the contact form on the test site fails to actually send the form data to email although it suggests that it has by linking to the thanks page.
My server is unix based running Apache1.3.33 with php 4.3.10 cgi and mysql api 4.0.12.
Unfortunately register_globals is set to ON and I can’t alter this either with a php.ini file in the root (this has no effect) or an .htaccess file (anything but a blank .htaccess file causes a server unavailable message on all pages).
This isn’t the problem however as I then installed modx on my second site as a test. I installed it identically and this one works just fine with no issues at all??
I then asumed it was an installation error as both sites are similarly hosted so I both reinstalled to my first site (no change same problems) and even did a second installation to a different directory on my first site but it has all the same issues.
Its doin ma head in!!
Any ideas or suggestions what I may be doing wrong or how I can fix it?
Should have added I am using modx 9.6.3 and my PC runs Windows XP using IE7 or Opera 9 to access all my sites