We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 7804
    • 80 Posts
    I have noticed that we are seeing many MODx parse errors in our system events log - about 1 every 2 minutes.

    We are running 0.9.6.1 on Apache/PHP5.2.9. We average 26000+ pageviews a day, so I guess using some sloppy math it comes out to 1 parse error every 36 page views (1 error x 2 minutes = 30 errors an hour x 24 hours = 720 errors a day; 26000 pageviews / 720 errors = 36 errors/pageview).

    The error we are seeing below:


    To me it looks like something is trying to access the "tmp" directory on the top level of our server. I examined this directory and it has a couple of empty folders that look related to webstats. Has anyone seen this before, or does anyone know how I could get to the bottom of this?
      • 22303 MODX Staff
      • 10,725 Posts
      This is a problem with permissions and the php session.save_path ini setting. How it could be happening only on some page views is a mystery, but you might want to make sure there are not any existing session files in the /tmp/ directory that are not writable by the PHP process.
        • 7804
        • 80 Posts
        We are using a load-balanced system with 3 dedicated server machines in a cluster; do you think the issue could be that the session is saved on one machine and when the load balancing system switches over to another machine’s server, that one does not have access to the first machine’s session file?
          • 25663 MODX Staff
          • 12,272 Posts
          That’s exactly what’s going on don juan.
            Ryan Thrash, MODX Co-Founder
            Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
            • 22303 MODX Staff
            • 10,725 Posts
            You might want to try using the memcached session_handler in a load-balanced environment; see http://php.net/manual/en/memcached.sessions.php for more information.
              • 7804
              • 80 Posts
              Thanks guys. cool
                • 7804
                • 80 Posts
                We fixed this issue by creating a hard link on the servers in a shared temp directory. Thanks again for all your help. (This resolved a bunch of login issues with all of our server applications besides MODx as well.) smiley
                  • 25663 MODX Staff
                  • 12,272 Posts
                  Glad it’s working don juan. What do you have running MODx that needs 3 front end servers to serve it? smiley
                    Ryan Thrash, MODX Co-Founder
                    Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
                    • 7804
                    • 80 Posts
                    Quote from: rthrash at Mar 25, 2009, 04:36 PM

                    Glad it’s working don juan. What do you have running MODx that needs 3 front end servers to serve it? smiley

                    A popular text editor: http://www.ultraedit.com. It’s probably a little bit overkill, but we are very much a "belts and braces"-minded organization wink and we do have a lot of downloads.