We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 26425
    • 15 Posts
    hey folks - frustrated ModX noob here. was having some issues with these files and accidentally deleted them, with no backup. now the site won’t load anymore. i get this:

    « MODx Parse Error »

    MODx encountered the following error while attempting to parse the requested resource:
    « PHP Parse Error »

    PHP error debug
    Error: DocumentParser::include(/home/ilahjarv/public_html/scottrlooney/assets/cache/sitePublishing.idx.php) [documentparser.include]: failed to open stream: No such file or directory
    Error type/ Nr.: Warning - 2
    File: /home/ilahjarv/public_html/scottrlooney/manager/includes/document.parser.class.inc.php
    Line: 525
    Line 525 source: @include $this->config["base_path"] . "assets/cache/sitePublishing.idx.php";

    can anyone point me to a procedure to regenerate these files correctly? i’m dead in the water until i do. do i have to reinstall Modx from scratch?

    any help appreciated...

    best,

    scott
      • 33372
      • 1,611 Posts
      You should be able to upload the blank cache files that came with your MODx installer, login to the manager and refresh the site (clear the cache). You will also need to reset all of the general site configurations, since those are stored in the siteCache file. That’s worked for me when these files have become corrupted.
        "Things are not what they appear to be; nor are they otherwise." - Buddha

        "Well, gee, Buddha - that wasn't very helpful..." - ZAP

        Useful MODx links: documentation | wiki | forum guidelines | bugs & requests | info you should include with your post | commercial support options
        • 26425
        • 15 Posts
        thanks ZAP! by resetting the general site configurations, what do mean by that? what does that exactly consist of?

        scott
          • 33372
          • 1,611 Posts
          Just go into Tools -> Configurations in the Manager. You’ll see that all of the settings are back at their defaults (for example, your site will be called "My MODx Site" again). Re-enter the configs that you want in there, save, and you should be back to normal.
            "Things are not what they appear to be; nor are they otherwise." - Buddha

            "Well, gee, Buddha - that wasn't very helpful..." - ZAP

            Useful MODx links: documentation | wiki | forum guidelines | bugs & requests | info you should include with your post | commercial support options
            • 26425
            • 15 Posts
            out of the frying pan...

            well, the site no longer throws up PHP errors (its just blank), but now we get to a bigger issue. i can’t log into the manager now either. observe:

            Warning: fopen(/home/ilahjarv/public_html/scottrlooney/manager/media/style//login.html) [function.fopen]: failed to open stream: No such file or directory in /home/ilahjarv/public_html/scottrlooney/manager/includes/accesscontrol.inc.php on line 129

            Warning: filesize() [function.filesize]: stat failed for /home/ilahjarv/public_html/scottrlooney/manager/media/style//login.html in /home/ilahjarv/public_html/scottrlooney/manager/includes/accesscontrol.inc.php on line 130

            Warning: fread(): supplied argument is not a valid stream resource in /home/ilahjarv/public_html/scottrlooney/manager/includes/accesscontrol.inc.php on line 130

            Warning: fclose(): supplied argument is not a valid stream resource in /home/ilahjarv/public_html/scottrlooney/manager/includes/accesscontrol.inc.php on line 131

            part of the reason i was tinkering around with the cache files is that i kept getting these errors in the manager every time i saved or edited files in the manager. i read some info on a thread about this issue, but at the time i didn’t think my issue was that bad because i could still log into the manager. now i can’t and i still keep getting the errors.

            any clue what this error’s about?
              • 20413
              • 2,877 Posts
              Maybe corrupt file transfer...
              If retransferring all files and run the install upgrader don’t install demo page (that will overwrite your existing files).
                @hawproductions | http://mrhaw.com/

                Infograph: MODX Advanced Install in 7 steps:
                http://forums.modx.com/thread/96954/infograph-modx-advanced-install-in-7-steps

                Recap: Portland, OR (PDX) MODX CMS Meetup, Oct 6, 2015. US Bancorp Tower
                http://mrhaw.com/modx_portland_oregon_pdx_modx_cms_meetup_oct_2015_us_bancorp_tower
                • 33372
                • 1,611 Posts
                The manager is not finding the value of its theme (note the two slashes between style and login). This value should be set in your siteCache file. So maybe you didn’t upload it correctly, or it’s corrupted, or it has the wrong permissions...?
                  "Things are not what they appear to be; nor are they otherwise." - Buddha

                  "Well, gee, Buddha - that wasn't very helpful..." - ZAP

                  Useful MODx links: documentation | wiki | forum guidelines | bugs & requests | info you should include with your post | commercial support options
                  • 26425
                  • 15 Posts
                  OK ZAP (and mrhaw) thanks, i have a workaround. i moved files in the ModX Light manager theme one folder upwards, which made me able to log into the manager. once i was in i manually changed the manager theme to something else other than the ModX light theme, saved the file and now the site seems to load. it did throw up an error of ’Failed to Update settings value’ but it’s done this a lot before and i never paid much attention, since even though it has that error the changes seem to be saved.

                  however, could that be the root cause of a corruption problem which affects the cache files and/or the manager if the error message is displayed too many times?

                  at any rate things seem to be back to where they were earlier today so that’s progress. once again, thanks for all the help!

                  scott
                    • 33372
                    • 1,611 Posts
                    Hmm. You should not be getting any errors, and ignoring them probably won’t help matters. I would definitely reupload all of the MODx files and make sure that your permissions are set properly and see if that resolves them.
                      "Things are not what they appear to be; nor are they otherwise." - Buddha

                      "Well, gee, Buddha - that wasn't very helpful..." - ZAP

                      Useful MODx links: documentation | wiki | forum guidelines | bugs & requests | info you should include with your post | commercial support options