On my local dev server it’s fine but when I try my live server I can’t download or open pdfs.
I keep getting a server error message (500).
Anyone else had this problem or know how to fix it?
Thanks
Content Creator and Copywriter
Problem seems to be related to the name of the pdfs
eg they are "080619 acwa issues paper final.pdf"
but if I change them to "080619-acwa-issues-paper-final.pdf "
ie with the "-" in place they seem to work.
Anyone know why this would be?
Content Creator and Copywriter
-
MODX Staff
- 12,272 Posts
Some servers won’t allow spaces in filenames, I think.
Ryan Thrash, MODX Co-Founder
Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
If you put %20 where every space is, they make work as they are.
Actually, I’m a little embarrassed it turns out it was my folder name.
It was PDF, and all the links were to pdf, which worked fine on the local server but not the live one.
A quick change and all is well.
Content Creator and Copywriter
Case sensitive names are an issue on some servers (not sure how to deal with it). I had this same error on a site that was on a server who was less picky and allowed .PNG to accessed as .png. Then migrated and many images stopped working, after some hair pulling I found the problem. I wonder if there is an htaccess command to bypass this?
Putting ’NC’ (for no case) in the .htaccess file rewrite rule is supposed to help but it hasn’t always worked for me.
I started putting *all* filenames in all lower-case quite a while ago. That way, it’s one problem I never have to worry about.