We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 25551 ☆ A M B ☆
    • 1,231 Posts
    HI, i want to include a status monitor for an online gaming chat program on my site but it’s not working.

    I changed the host and on the old host this worked as a snippet

    <?php
    include("http://www.tsviewer.com/ts_viewer_pur.php?ID=44083&bg=&type=&type_size=11&type_family=1&info=1&channels=1&users=1&type_s_weight=normal&type_s_style=normal&type_s_variant=normal&type_s_decoration=none&type_s_weight_h=normal&type_s_style_h=normal&type_s_variant_h=normal&type_s_decoration_h=none&type_i_weight=normal&type_i_style=normal&type_i_variant=normal&type_i_decoration=none&type_i_weight_h=normal&type_i_style_h=normal&type_i_variant_h=normal&type_i_decoration_h=none&type_c_weight=normal&type_c_style=normal&type_c_variant=normal&type_c_decoration=none&type_c_weight_h=normal&type_c_style_h=normal&type_c_variant_h=normal&type_c_decoration_h=none&type_u_weight=normal&type_u_style=normal&type_u_variant=normal&type_u_decoration=none&type_u_weight_h=normal&type_u_style_h=normal&type_u_variant_h=normal&type_u_decoration_h=none&skin=ts2_classic");
    ?>


    and then called on it using [!ts!] which worked.

    Moving to a new host... i followed the exact same setup but I’m getting this error

    « MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource:
    « PHP Parse Error »
     
    PHP error debug
      Error: 	include() [function.include]: URL file-access is disabled in the server configuration	 
      Error type/ Nr.: 	Warning - 2	 
      File: 	/home/sites/err-clan.com/public_html/manager/includes/document.parser.class.inc.php(769) : eval()'d code	 
      Line: 	2	 
     
    Parser timing
      MySQL: 	0.0067 s	(3 Requests)
      PHP: 	0.0325 s	 
      Total: 	0.0393 s


    Any ideas what it could be???

    Thanks!
      Ross Sivills - MD AugmentBLU Edinburgh, Scotland UK
      AugmentBLU - MODX Partner

      BLUcart - MODX Revolution E-Commerce & Shopping Cart
      • 25551 ☆ A M B ☆
      • 1,231 Posts
      Thanks for explaining it to me...

      I’ve just contacted my host and they do not block any files. I still have my old hosting and the script still is running so it’s not the site providing the service that is blocking anything. What else can I do to see what is causing the error?

      Thanks
        Ross Sivills - MD AugmentBLU Edinburgh, Scotland UK
        AugmentBLU - MODX Partner

        BLUcart - MODX Revolution E-Commerce & Shopping Cart
        • 25551 ☆ A M B ☆
        • 1,231 Posts
        allow_url_fopen On On
        allow_url_include Off Off

        Time to email them again. LOL Thanks for the info on that. grin
          Ross Sivills - MD AugmentBLU Edinburgh, Scotland UK
          AugmentBLU - MODX Partner

          BLUcart - MODX Revolution E-Commerce & Shopping Cart