We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 18193
    • 8 Posts
    Hello

    I had to move a complete site made with MODx on local to work on it, MODx installation went great and I’ve understand the basics of how MODx works.

    I can actually launch the site with the regular index page, but here comes trouble. Any link to another page end up with a 404 error. Seems like there’s an error in the documents linking each other.
    In the manager, I can display any child document, but all the containers documents show a 404 error.

    I checked root path in the MODx settings and the redirection in the .htaccess, I tried some modifications, but nothing work.

    I’m using EasyPhp 2.0b1 with apache 2.2.3, php 5.2.0 and mySQL 5.0.27, everything on windows XP SP2.
    The browser used is firefox.
      • 6726
      • 7,075 Posts
      You mean you move from local to a remote server ?

      There are a couple of items to check when you do so, and a very good checklist is here:
      http://wiki.modxcms.com/index.php/Moving_Site_To_Another_Location

      If that does not help, then we’ll dig deeper !
        .: COO - Commerce Guys - Community Driven Innovation :.


        MODx est l'outil id
        • 18193
        • 8 Posts
        I did read this page dozen of times :p

        And no it was from a remote server to local.
          • 4310
          • 2,310 Posts
          If you have friendly urls enabled this can cause 404 errors on local Windows machines.
          Maybe your server setup isn’t allowing for the .htaccess rewrite function.
            • 18193
            • 8 Posts
            Friendly URLs are disabled, and I moved the site files so there’s no need of RewriteBase and it still doesn’t work undecided
            I’m sure the problem comes from a little tiny thing in the config but I can’t think of anything, I’m still digging thought.

            Thanks for trying to help me.
              • 18193
              • 8 Posts
              I found it ! Haha

              The URLs I was clicking were coded in html, not using MODx’s Documents IDs...

              And I spent a day on that >:(

              Thank you anyway for trying to help me. (And sorry for double post)