We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 29061
    • 4 Posts
    I’ve applyed the chmod to all folders/files (that needed) with 0666 (also with 0777) but nothing happened ... Everything is fine except
    Checking if assets/cache/siteCache.idx.php file is writable: Failed!

    Checking if assets/cache/sitePublishing.idx.php file is writable: Failed!

      • 5274
      • 177 Posts
      Try issuing these commands from the web site root directory:

      chmod -v 777 assets/cache/siteCache.idx.php
      chmod -v 777 assets/cache/sitePublishing.idx.php
        • 29061
        • 4 Posts
        [19:00:14] chmod -v 777 assets/cache/siteCache.idx.php
        [19:00:14] 550 Could not change perms on 777 assets/cache/siteCache.idx.php: No such file or directory
        [19:00:14] chmod -v 777 assets/cache/sitePublishing.idx.php
        [19:00:14] 550 Could not change perms on 777 assets/cache/sitePublishing.idx.php: No such file or directory

        It’s awefull!!! Why??? The path’s are corect!
          • 5274
          • 177 Posts
          You need to issue those commands from the directory just above the assets directory. If you continue to get errors then have you checked if those files even exist? Another way is to change directory into assets/cache and issue simpler commands:

          cd assets/cache
          chmod -v 777 siteCache.idx.php
          chmod -v 777 sitePublishing.idx.php
            • 29061
            • 4 Posts
            the file exist because i verified that ... whatever I use SmartFTP ... and I succesfully changed the chmod but I don’t know why it doesn’t work with those files...

            with the other’s works fine...

            maybe it’s the host?
              • 28042 ☆ A M B ☆
              • 24,524 Posts
              Are you sure? From where are you trying to change them? Those are relative paths, so you’d need to be in the MODx root. It’s also possible that it doesn’t like relative paths like that; if you are in the MODx root try adding ./ in front of the paths.
                Studying MODX in the desert - http://sottwell.com
                Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                Join the Slack Community - http://modx.org
                • 29061
                • 4 Posts
                It was from my host, now I changed it... succesfully installed . but
                MODx is not currently installed or the configuration file cannot be found.

                Do you want to install now?

                where i should put config.cfg and what it contains ?

                Solved!