We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 33480
    • 27 Posts
    hi all,

    i am new to ModX and is still grappling around a bit. I’ve successfully installed the ModX over my WAMP5 on a WinXP, but aside from the home link, eveything else results to the NOT FOUND error.

    I read somewhere about configuring .htaccess but this solution is more on the server side (online).

    am testing the website locally on my desktop.

    bests,

    jun
      • 7231
      • 4,205 Posts
      Are you reffering to the demo site content or is this a clean install with no content? If the later make sure that the documents are published or else they will not be available.

        [font=Verdana]Shane Sponagle | [wiki] Snippet Call Anatomy | MODx Developer Blog | [nettuts] Working With a Content Management Framework: MODx

        Something is happening here, but you don't know what it is.
        Do you, Mr. Jones? - [bob dylan]
        • 33480
        • 27 Posts
        i am referring to the demo site. I tried adding my own pages (have read the documentation) and had set these to PUBLISH but won’t appear just the same. sad
          • 7231
          • 4,205 Posts
          Did you turn on Friendly URL? If so you need to configure the .htaccess file to conform to your server settings. If you do not want to worry about that in the development environment then turn off Friendly URL in the site configurations.
            [font=Verdana]Shane Sponagle | [wiki] Snippet Call Anatomy | MODx Developer Blog | [nettuts] Working With a Content Management Framework: MODx

            Something is happening here, but you don't know what it is.
            Do you, Mr. Jones? - [bob dylan]
            • 4310
            • 2,310 Posts
            Just to back up what dev_cw said.
            I have not got friendly urls to work on my Win XP WAMP set up and have given up trying.
            It always returns an error.
            Make sure you rename .htaccess file back to ht.access and disable friendly urls in the manager - configuration settings.
            Hopefully your pages will appear.

            David
              • 4310
              • 2,310 Posts
              I turned mod_rewrite on but I still get an internal server error if I use a .htaccess file.
              I should point out I use "wampserver" not XAMPP

              David
                • 33480
                • 27 Posts
                Yehey, turned off the friendly URL and everything is working now.

                Thanks all.

                ;D