We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37044
    • 68 Posts
    Hello Modx community!

    I am a complete Modx nube so please forgive me for getting back to basics. About to install and I noticed that on the ’requirements’ page (http://rtfm.modx.com/display/revolution20/Server+Requirements) it states that

    PHP Compatibility ---- 5.1.1 and above (excluding 5.1.6 and 5.2.0)

    My shared hosting is running PHP v 5.2.9

    Now my actual question is 5.2.9 a completely different version of PHP to 5.2.0(not allowed) or are they both essentially the same PHP version with some minor updates. So as I have 5.2.9 can in install Modx or not????


    Pls help!!
      • 26016
      • 561 Posts
      I think that should be OK. Any server varies, of course. But for instance, I have 5.2.14, and it’s smooth as glass.
        MODx and Wordpress development
        Linux, PHP 5.2, MySQL 5.0, Evo 1.05, Revo 2.08-pl, Firefox 4
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        The two version you mention have bugs that break MODx. The later minor versions fixed the bugs.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org