A client of mine who uses Modx 0.9.5 wants to upgrade to the new Revolution 2.0 version. I have two questions:
1 - I read the upgrade instruction and apparently nothing says that I can’t upgrade from 0.9.5 to 2.0, but I tried to do it in my local dev server and I wasn’t able to do it because of some DB mysql connection problem. I suppose that it’s possible to upgrade from 0.9.5 to 2.0, if that’s not the case can someone point to URLs where I can read more about how to migrate to the new version?
2 - In order to upgrade/migrate I need to ask the hosting service to upgrade my client’s account to PHP5. In the same hosting account my client has another modx 0.9.5 installation which they don’t want to migrate to 2.0 right now. Would that version still work under PHP5?
Last but not least I find the General Requirements (
http://modxcms.com/learn/general-requirements.html) confusing or misleading. Under "Software Stack" it says "PHP Compatibility: 4.3.11 and above" and only under "For optimal results" does it say "PHP 5.2.9 or later". That made me think that I could easily upgrade withouth having to change the current PHP version. However when I run the setup script I got: "FATAL ERROR: MODx Setup cannot continue. Wrong PHP version! You’re using PHP version 4.4.4, and MODx requires version 5.1.1 or higher." If that’s the real case, then the info under "Software Stack" is totally incorrect!