We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 8425
    • 159 Posts
    Hello,
    I’m using WebloginPE 1.3.1 as follow:
    [!WebLoginPE? &lang=`en` &type=`simple` &regType=`verify` &loHomeId=`20` &liHomeId=`1` &pruneDays=`7` &loginFormTpl=`FormLoginPE` &successTpl=`LoginSuccess` &registerTpl=`Register` &tosChunk=`TOS` &regRequired=`email,username,fullname,formcode,tos` &registerSuccessTpl=`FormLoginPE`  &resetTpl=`ResetPwd` &groups=`Registered Users` &profileDeleteTpl=`DeleteProfile` &activateTpl=`Activate` &profileTpl=`Profile` &notify=`[email protected]`!]


    I checked the manager error log and I have numerous entry of WLPE errors as follow: "Redefining already defined constructor for class WebLoginPE"

    Does any one has seen this error before? Any hints on how to fix it? Thank you
      • 8425
      • 159 Posts
      Am I the only one encountering this issue....?
      Thankd
        • 3749
        • 24,544 Posts
        I haven’t seen that error, but the message means that the WLPE class file is being included more than once. A few possibilities come to mind:

        1. More than one WLPE call on a single page.
        2. A WLPE call in one of your tpl files.
        3. A bug in the WLPE code.
        4. Calling WLPE (or including the class file) in your own snippet on a page that has a WLPE call.

        One solution might be to edit the WLPE class file and wrap the class in this:

        if (!class_exists("WebLoginPE")) {
        class WebLoginPE {
        . . .
        }
        }
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 20413
          • 2,877 Posts
            @hawproductions | http://mrhaw.com/

            Infograph: MODX Advanced Install in 7 steps:
            http://forums.modx.com/thread/96954/infograph-modx-advanced-install-in-7-steps

            Recap: Portland, OR (PDX) MODX CMS Meetup, Oct 6, 2015. US Bancorp Tower
            http://mrhaw.com/modx_portland_oregon_pdx_modx_cms_meetup_oct_2015_us_bancorp_tower
            • 8425
            • 159 Posts
            Thanks for your replies and help. I updated the file webloginpe.class.php to remove the duplication. It works fine now....
              • 2371
              • 29 Posts
              Double call snippet on a page ( Двойной вызов сниппета на одной из страниц сайта ) wink
                • 40024
                • 72 Posts
                Hello,i had the same error report.For me what fixed it was to remove this part of the code:
                function WebLoginPE($LanguageArray, $dateFormat = '%A %B %d, %Y at %I:%M %p', $UserImageSettings = '105000,100,100', $type = 'simple')
                	{
                		$this->__construct($LanguageArray, $dateFormat, $UserImageSettings, $type);
                	}


                in webloginpe.class.php, located around lines 163-166.
                Apparently,these lines were used for PHP4 compatibility. If your server runs on PHP4 however,these lines of code might be needed, so i suggest trying other solutions first.