We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14107
    • 21 Posts
    Hello

    I recently upgraded a site to Modx 2.7.1. Now all I see is the home page. No sub pages show at all.

    Also in my error log I'm seeing PHP Warning: constant(): Couldn't find constant 32759 in /home/xxxxxxxx/public_html/core/model/modx/modx.class.php on line 678

    I found another thread in the forum that suggested the error above may be due to missing fields in database tables due to missing out versions when upgrading, but I've checked and all fields are there.

    Can anyone help?

    This question has been answered by jgr. See the first response.

      • 38783
      • 571 Posts
      What version of PHP are you running on the site? It might be that 'constants' are not supported if running an older version.

      https://www.php.net/manual/en/language.constants.php
        If I help you out on these forums I would be very grateful if you would consider rating me on Trustpilot: https://uk.trustpilot.com/review/andytough.com

        email: [email protected] | website: https://andytough.com
      • discuss.answer
        • 14107
        • 21 Posts
        Hi Andy

        Thanks for your suggestion. I think it's PHP 5.4.

        However, since I posted, I turned off friendly urls and found the sub-pages showed up. When I re-enabled friendly urls, everything was back to normal!

        So the problem has disappeared.

          • 3749
          • 24,544 Posts
          I think you could have solved it with Manage -> Clear Cache -> Refresh URIs.

          Turning FURLs back on would probably have triggered the URL update.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 14107
            • 21 Posts
            Thanks Bob - I wasn't aware of that option. It's one to bear in mind. I had cleared the cache manually by deleting the files.