Subscribe: RSS
  • Hi all. Please advise what should I do. A couple days ago , my site changed to the https protocol, after that I receive this error action_err_ns. When I run synchronization of data, it proced multiple requests one after another, an amoun of requests is eqaul 600-620, and in one time it complete successfull, and other time may interrupted after any amount of requests. Cache cleared already multple times but didnt help. modx version 2.5.4
    • I'd suggest using the UpgradeMODX extra to upgrade your site to Version 2.6.0, then 2.6.5 immediately. There are serious security issues in your version and the upgrade might help with the problem.

      Be sure the server_protocol System Setting is set to https. You may also need a rewrite rule in .htaccess to make sure all requests are forced to use https.

      Also, in the program you're running, a hard-coded 'http' reference (like an image or JS source file) could cause the problem.
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/MODx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • action_err_ns means the action isn't set (ns = not set). What I suspect has happened is that (POST) requests to a connector is being sent to your HTTP URL, get redirect to HTTPS, and therefore drop their POST data (including the action).

        That should be visible in the network tab, and would be fixed by updating where-ever that http url is coming from
          Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with remote management features to make the MODX world a little better.

          Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
        • Quote from: BobRay at Jan 14, 2019, 06:58 PM
          I'd suggest using the UpgradeMODX extra to upgrade your site to Version 2.6.0, then 2.6.5 immediately. There are serious security issues in your version and the upgrade might help with the problem.

          Be sure the server_protocol System Setting is set to https. You may also need a rewrite rule in .htaccess to make sure all requests are forced to use https.

          Also, in the program you're running, a hard-coded 'http' reference (like an image or JS source file) could cause the problem.

          I'll try to upgrade. Thanks for your advise [ed. note: andrace last edited this post 1 week, 2 days ago.]
          • Quote from: markh at Jan 14, 2019, 07:32 PM
            action_err_ns means the action isn't set (ns = not set). What I suspect has happened is that (POST) requests to a connector is being sent to your HTTP URL, get redirect to HTTPS, and therefore drop their POST data (including the action).

            That should be visible in the network tab, and would be fixed by updating where-ever that http url is coming from

            Thanks for your advice, but I think that if it was be as you explained, requests not proceed at all whole time, but not time to time. Anyway I verifyed a js code, and within files all links is relative and not absolute