I am a Modx user. My site is hosted on Bluehost. My site was hacked so I backed things up and cleaned things out. I downloaded the new modx but it will not install. This issue extremely difficult to diagnose, and this is unfortunate.
I am stuck on the part where it says "Test database server connection and view collations". This fails. There are many many posts on this, none of them giving a solution.
My web browser seems to indicate an error interpreting one of the underlying .js files (attached).
<
[ed. note: friendlyjoe last edited this post 7 years, 8 months ago.]
[SOLVED] - While the terminal PHP version was reporting the latest PHP, the configured PHP version on the cPanel was determining the actual configuration and was point to (**shock**) an older PHP version.
Fixing this and bumping up to PHP 5.6 fixed this.
<
Ah great you got it going. I saw your post last night but couldn't think of the reason why. Of course it was php, I should have thought of that
good suggestions, the core system is improving all the time.