On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • HI, I have a MODx Evolution 1.0.3 website.
    It is working fine till but I can't go to the manager view anymore.
    I can login, with errors, but It doesn't go to a manager view, but gives me that strip at the top(see attached). If I click `Edit Resource` it gives a pop up with bunch of warnings.
    Any help highly appreciated.
    If somebody is willing to help I can offer some compensation (the data is very important to me).
    Thanks!
    • The PHP version on your server has probably been updated and now your outdated version of Evo no-longer works properly

      1.0.3 is massively outdated, you need to update it for it to work

      You can download the latest version from GitHub, but I think you will need to update in steps, as the jump might be to big from 1.0.3 to 1.4.7

      A quick list of available downloads (although not complete) can be found here, the latest stable version (1.4.7) can be found here

      If you struggle, post your problem / situation in the Evolution Github page
      • Quote from: iusemodx at Dec 29, 2018, 11:54 PM
        The PHP version on your server has probably been updated and now your outdated version of Evo no-longer works properly

        1.0.3 is massively outdated, you need to update it for it to work

        You can download the latest version from GitHub, but I think you will need to update in steps, as the jump might be to big from 1.0.3 to 1.4.7

        A quick list of available downloads (although not complete) can be found here, the latest stable version (1.4.7) can be found here

        If you struggle, post your problem / situation in the Evolution Github page

        Thanks a lot for the reply.
        I've checked the PHP version on the server - its 5.6.39 - on the requirements page for 1.0.3 it says that minimum 5.5.x, recommended 5.6.x. SO, not sure this is the issue.
        Do you think I still can try to update even if my current installation is not working? Also, do you know which version could handle the jump to 1.4.7(I will be gradually updating 1.0.3)?
        • Steps I have personally carried out: 1.0.9 => 1.2.1 => 1.4.5

          I haven't updated to 1.4.7 as of yet, but will be doing so in the new year

          If I were you, I would first try 1.0.3 => 1.2.1, then test if it works. I am not sure anymore, but a later version no-longer supports MYSQL, which would mean it wont work properly on your server, as your PHP version needs to be updated to support MYSQLi

          Simply make a backup of everything you have on the server and don't forget to backup the database as well, then update as normal - if it works, great, if not, post in the Evolution Github issues page.

          DO NOT update to 2.0.0, that's an alpha release and shouldn't be used in a live environment